Home / GitHub Page

Bug here or in my WebDAV?: not syncing when "@"/"%40" in URL

I’m using Joplin Version Joplin 1.0.179 (prod, linux) on Xubuntu 16.04. (Although I got the same error on Android, have not tried on Windows yet)

I have tried using the sync feature with my webDAV service (an owncloud-like university service) and got the following error ([USER] is a mask for my username):
Last error: Error: href /remote.php/dav/files/[USER]@uni-muenster.de/Joplin-notes/.lock/ not in baseUrl https://uni-muenster.sciebo.de/remote.php/dav/files/[USER]%40uni-muenster.de/Joplin-notes nor relativeBaseUrl /remote.php/dav/files/[USER]%40uni-muenster.de/Joplin-notes

Now reading this thread: https://github.com/laurent22/joplin/issues/470
I see that maybe the @ in the URL is the problem.
The question is: Is this a bug in my webDAV service or is this handled in Joplin, because in the configuration I wrote it with %40 like in the BaseUrl above.

(The directory .lock exists on the server)

If you tried with %40, did you also try with @? I believe that’s a bug in WebDAV as the URL is %40... but they send it decoded in the XML, so there’s a mismatch and Joplin gives up.

Changing it to @ in the URL has solved it, yes. Thank you for the help.

1 Like