Home / GitHub Page

Android out of sync

#21

My android app is way out of sync. I’ve added a few notes from Windows 10, created new notebooks and rearranged a bunch of notes. None of this can be synced with the android app at all. I have E2EE enabled. The sync status doesn’t output any errors on both applications.

I have an installation on Ubuntu as well but I might need to do a clean install of that OS because of some other issues. However while setting up Joplin on Ubuntu I created y mistake a new encryption key because I was confused. When I noticed that the app wasn’t decrypting the notes it was syncing I realised I was using a wrong mastrkey and I fixed it. It worked but now I have an unused masterkey inside Joplin. The only error I can see in the log is about that masterkey for which I don’t have the password anymore (I thought it really didn’t matter and that I could delete it completely, but I couldn’t).

Let me tell you, this app is free, open source and potentially a great alternative to Evernote and I LOVE and support all this. But honestly in the actual state of development it’s really a struggle to use it and make it work properly, even for more techy users like myself that can get their hands dirty with quite complex configurations, logs and stuff.

#22

What do you sync with?

Any error in the Android app log?

#23

I sync with Nextcloud. No errors in the log, if we don’t consider this:

“No master key is defined as active. Check this: Either one or more master keys exist but no password was provided for any of them. Or no master key exist. Or master keys and password exist, but none was set to active”.

As I wrote before, I have 2 master keys: an unused one which I couldn’t get rid of without password and the actual correct one with the correct password and set as active (as far as I can tell).

#24

Can you take a screenshot of the log showing your last sync?

#25

here you go