A question about mathematical symbols

Operating system

Windows

Joplin version

2.14.19

Desktop version info

Joplin 2.14.19 (prod, win32)

客户端 ID: 9b3286b007194601b623c10c4faf86bc
同步版本:3
配置文件版本:46
支持的密钥链:是

修订:971c4e5

Backup: 1.4.0
Note Tabs: 1.4.0

Sync target

File system

Editor

Markdown Editor

What issue do you have?

A question about mathematical symbols
When I entered the mathematical formula, for the latest version of Windows Joplin, typing "\ne" or "\neq" or "\not" did not correctly display the preview unequal sign. How to solve this problem?

Screenshots

That looks like a font-loading issue! (The 2-19s should also be in a serif font).

Here are a few things that might help us determine what the issue is:

  • Does a note with just $\neq$ work? (In the past, \tags have caused issues).
  • Do you have any custom CSS? (Settings > Appearance > Advanced > Custom stylesheet for rendered markdown).

Yes, after confirmation, this is indeed a problem with font loading.
First of all, I did not have a similar situation on other devices, and it can be displayed normally.
Then I checked the CSS file and found that I had used typera's Settings and copied its CSS into the userchrome.css and userstyle.css files.

*{font-family: -apple-system,BlinkMacSystemFont,Segoe UI,Roboto,Oxygen,Ubuntu,Cantarell,Fira Sans,Droid Sans,Helvetica Neue,sans-serif;
    -webkit-font-smoothing: antialiased;
}

This problem was solved when I restored CSS to default.

1 Like