Sync notes between CLI and desktop with e2ee

I am trying to sync notes between that are created with desktop app with the cli app.
I have set the to 2 and sync.2.path to my sync folder.

Still i could not see the notes in CLI application?

Any help?

Edit #1:
OS Version: Mac OS Catalina 10.5.4
Joplin Desktop: 1.0.201
Joplin CLI (using npm): 1.0.163

Edit #2
log.txt (24.2 KB)

What operating system are you using for both and are both being ran at the same time?

using macos desktop app and command line app

Are you running both at the same times or one right after you close the other?

Mainly using the desktop app for working with notes. I was trying to use the cmd line app just to configure a script to export notes and push it to a repo.

I tried both using the both at the same time and just using command line with desktop app closed.

Thanks for clarifying that. Joplin normally doesn’t allow running multiple instances of it on the same platform. If you could add as much info to the original post (like osx version and versions of both apps) that’d help you get better help here. I’m not sure how to fix the issue but there are definitely smart people here. :grin:

Sure, I will add it.

Do you suggest any other method to push the encrypted notes to a git repo and later, if need restore specific notes back to Joplin?

I’m trying to find it, but there’s a backup script for git floating around here, but understand that it and similar services aren’t officially supported and can mess up your notebooks and notes long term. Joplin is built around cloud syncing with Filesystem sync being more of a workaround for unsupported services or use cases but not the main route to go.

Maybe this?

1 Like

Thanks, @roman_r_m. That’s the one!!!

Yes, I saw this too. but for this to work. The cmd line Joplin should have access to all the notes created by the Desktop application, right?

Definitely. I forgot you had the problem of them not speaking to each other. Could you attach ~/.config/joplin/log.txt to your original post? Just upload it. You don’t need to copy and paste it here. Thanks


Perhaps a symlink would work if your OS has them? People reported issues using symlinks but I think if you access your profile via symlink only for backup (ie read only) you should be fine.

@roman_r_m, Mac’s are BSD based which is based on Unix, so symlinks are embedded in their DNA. Haha

I was on mobile so didn’t want to scroll up to check if the OP had mentioned their OS

1 Like

I tried symlinking too, still having the issue. Not sure, if i am doing it right way for joplin to recognize the profile.

Have you tried running the CLI with --profile ?

Yes, that works to see the notes using CLI. But the change is does not persist. I believe to do some kind of scripting, joplin CLI should default to the custom assigned profile.