Not allowed: PUT

Hello , i've an issue on Joplin server while i try to sync the phone app. The error code is:
Not allowed:PUT (Code 400).
I've tryed to delete my user and recreate, reinstall the phone app, but nothing is changed.

2021-06-23 11:15:24	stderr	2021-06-23 11:15:24: [error] App: 400: PUT /api/items/root:/testing.txt:/content : Not allowed: PUT 
2021-06-23 11:15:24	stdout	2021-06-23 11:15:24: App: PUT /api/items/root:/testing.txt:/content
2021-06-23 11:15:23	stdout	2021-06-23 11:15:23: App: POST /api/sessions

You need to upgrade to Joplin Server 2.x

I have the same issue with joplin/server:latest:

2021-06-27 15:03:52: App: Starting server v2.1.1 (prod) on port 22300 and PID 26...
2021-06-27 15:03:52: App: Running in Docker: true
...
2021-06-27 15:08:33: App: GET /api/items/root:/locks/*:/children (7ms)
2021-06-27 15:08:33: App: GET /api/items/root:/locks/*:/children (9ms)
2021-06-27 15:08:33: [error] App: 400: PUT /api/batch_items : Not allowed: PUT
2021-06-27 15:08:33: App: PUT /api/batch_items (1ms)
2021-06-27 15:08:36: App: GET / (0ms)
2021-06-27 15:08:36: App: GET /login (6ms)
2021-06-27 15:08:37: [error] App: 400: PUT /api/batch_items : Not allowed: PUT
2021-06-27 15:08:37: App: PUT /api/batch_items (1ms)
2021-06-27 15:08:45: [error] App: 400: PUT /api/batch_items : Not allowed: PUT
2021-06-27 15:08:45: App: PUT /api/batch_items (1ms)
2021-06-27 15:08:55: [error] App: 400: PUT /api/batch_items : Not allowed: PUT

Same error here with joplin/server:latest. Actually I just upgrated my jolin desktop app to 2.1.7. Seems like a bug with 2.1.7. Didn't have this issue with the previous version 2.x.x

Desktop app version? There's a bug with "ota" update. On the joplin site there isn't the 2.1.7 app. I think it is only pre-release version. Just download 2.0.11

Yep Mac desktop app. I got the upgrade notification today when opening up the app. It seems like it’s officially released today

I've seen the upgrade on github pages, but there isn't latest docker image yet...

Yes. So in my case 2.1.7 is the desktop app version not Joplin server version.

Yes i know. but the server version is the 2.0.11 right?

For Joplin Server you should use the latest beta, so that would be 2.1.7-beta I think (you can check on Docker Hub) and for now manually upgrade when a new beta is released. Eventually there will be a stable release on /latest you can rely on long term but for now it's best to always install the latest beta.

2 Likes

Thanks for your tips. But whe are talking about the joplin desktop app auto-update. Today there'is a new pop-up for upgrading to 2.1.7

1 Like

I was facing the same problem, updating docker image to 2.1.6-beta helped.

So, working combination:

  • Joplin desktop: 2.1.7
  • Joplin server: 2.1.6-beta
3 Likes

Thank you, 2.1.7 Desktop + 2.1.6-beta server work fine together

2 Likes

Can anyone explain how to install 2.1.6-beta server ?
I have:

root@XXX:/var/www/html/joplin-server# docker-compose images
Container Repository Tag Image Id Size

joplin-server_app_1 joplin/server latest 3310daee2c50 2.446 GB
joplin-server_db_1 postgres 13.1 407cece1abff 314.2 MB

and

root@XXX:/var/www/html/joplin-server# docker-compose up -d
joplin-server_db_1 is up-to-date
joplin-server_app_1 is up-to-date

I guess the "latest" tag for the docker image is not pointed to the 2.x versions. You have to edit you docker-compose.yml and change the tag to a 2.x version, as you can see here: Tags (in you case replace "latest" with "2.1.6-beta").

Worked great - thanks for that.

Any idea on when the latest branch will point to a version that will support the latest desktop client?

@eddydc welcome to the forum.

From what @laurent has said on this forum, the server software is currently still in beta and so all published images are beta versions and should be selected in the docker-compose file using its specific version, eg server:2.2.7-beta. When the server software is considered suitable to be "released" that image version will additionally be tagged :latest.

I believe that from then on :latest will indicate the latest Release version with :x.x.x-beta (or possibly something similar) indicating a Pre-release. So from then onwards if you use the :latest tag you will only get an image considered suitable for use.

It's similar to the way the desktop client software uses Release and Pre-Release.

IIRC laurent mentioned the current :latest tag was issued in error to Server v2.1.1-beta, hence it has not been used since as there is currently no release version. That being said, from what I have read the first release version of the server software is likely not that far off.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.