Operating system
Windows
Joplin version
3.7.18
Desktop version info
3.7.18, also previous versions
Sync target
Nextcloud
Editor
Rich Text Editor
What issue do you have?
Hello!
I'm encountering a bunch of strangeness, and I'm trying to see where it's cause likely is coming from. I've also not found a reference to anybody else having this problem, which isn't encouraging to me.
So...
I've been using Joplin with sync to NextCloud hosted on Hostwinds for several years without a problem. Suddenly, about a month ago, sync started erroring out even though nothing I'm aware of had changed (no upgraded clients, no changes in usage, no upgraded server components... that I know of). I tried upgrading NextCloud, ran into an error, and rather than troubleshoot that environment, I just installed a new instance of NextCloud using a different name (i.e. nextcloud3 instead of nextcloud2). All seemed to be well with the installation, but sync continued to fail. I checked with Hostwinds, and after a long back and forth, they claim everything they can see is working correctly (they refused to test from outside their firewall, and they only tested NextCloud, not Joplin itself) - however, they, in the past, have never admitted when anything was their fault (even after the issue mysteriously resolved after my trouble ticket pointed it out), so their statements may be incomplete, at the very least.
However, I have now tested Joplin on various clients, on various devices, on various networks (even a brand-new, fresh, no-data install), and the error is now consistent:
Last error: Error: Could not upgrade from version 0 to version 1: PUT .sync/version.txt: Unknown error 2 (404):
Nextcloud https://example.com/nextcloud/remote.php/webdav/Joplin:config sync.5.username YOUR_USERNAME
:config sync.5.password YOUR_PASSWORD
:config sync.target 5..."
Is this a new requirement, or does it happen by default - or why haven't I needed to do this in the past years?
Thank you, anybody, for any effort to get to the root of this.
Peace,
SJ

