Home / GitHub Page

[macos] trouble connecting to next cloud server

I am a new user and trying to connect to my NextCloud installation. I can reach (and sync) everything fine from my Android install, so I know that the server side is operating correctly. However, I get the following error on the MacOs Desktop side:

Last error: Error: PROPFIND 2ee48f80889447429a3cccb04a466072.md: Unknown error 2 (406): <head><title>Not Acceptable!</title></head><body><h1>Not Acceptable!</h1><p>An appropriate representation of the requested resource could not be found on this server. This error was generated by Mod_Security.

From the log file:

2019-02-19 09:54:29: "Operations completed: "
2019-02-19 09:54:29: “Total folders: 3”
2019-02-19 09:54:29: “Total notes: 5”
2019-02-19 09:54:29: “Total resources: 3”
2019-02-19 09:54:29: “There was some errors:”
2019-02-19 09:54:29: “Error: PROPFIND 2ee48f80889447429a3cccb04a466072.md: Unknown error 2 (406): Not Acceptable!

Not Acceptable!

An appropriate representation of the requested resource could not be found on this server. This error was generated by Mod_Security.


Code: 406
Error: PROPFIND 2ee48f80889447429a3cccb04a466072.md: Unknown error 2 (406): Not Acceptable!

Not Acceptable!

An appropriate representation of the requested resource could not be found on this server. This error was generated by Mod_Security.


at newError (/Applications/Joplin.app/Contents/Resources/app/lib/WebDavApi.js:348:11)
at WebDavApi.exec (/Applications/Joplin.app/Contents/Resources/app/lib/WebDavApi.js:377:10)
at
at process._tickCallback (internal/process/next_tick.js:188:7)”

Any thoughts on how to fix this? I have uninstalled and reinstalled the app once and tried it from the CLI version as well. Nothing seems to get it fixed.

Thanks!

If it works on Android it should work fine on desktop if you use the exact same parameters. Also maybe try temporarily disabling the mod_security module to possibly get better error messages.

Last time someone had this issue it was a typo in the webdav address.

I’ve type and re-typed it at least 5 times and it still doesn’t work on macOS. I also tried it on linux and it doesn’t work there either. Android and iOS work fine. Could it be something in my .htaccess file on the server side?

It could be possible but mostly if it works in Android and iOS, it should work well for Linux.

I am having this same error, was this ever resolved?

I can get Joplin ios app to connect and synch with my NextCloud but the MacOS desktop app for Joplin has not been able to connect or sync and has been giving me the same PropFind error. I have my NextCloud on shared hosting through Hostgator through my website and on version 16.0.3. Could there be server side issues preventing the desktop app sync?

IMO this was never a Joplin issue. There was nothing to resolve, at least not from Joplin’s side. I’ve been using Joplin with Nextcloud since the very beginning and have never experienced any of the issues people report here.

What happens, if you go with your browser to https://your.nextcloud.com/remote.php/webdav

Are you proxying traffic somehow? Local firewall blocking Joplin? Are you forcing http2 on the server?

Hmm, ok thanks for the info. I am able to access NextCloud through their desktop and mobile apps with my credentials and can sync the Joplin mobile apps with the same creds but just can’t get the desktop Joplin client to sync.

When I put the address in the browser it asks for my credentials, which I put it and then it gives me a message that the page is only accessible for WebDAV clients. So that side of things seems to be working fine.

I do not have a proxy on currently but I do have the built in Mac firewall active. I believe we do force https on the server side since it is for a law firm. I just set up the nextcloud so I wouldn’t mind sharing credentials if that would help someone try to replicate it. There must be something on my mac that is interrupting the sync or something.

Of note, when I remove my username and password from Joplin desktop app config page I do get a different error, a ‘No authorization’ error which would be expected. When I put the creds back in, the error reverts back to the PropFind error.

Reply to Laurent: This was the error given:

Completed: 09/09/2019 7:56 PM

Last error: Error: PROPFIND 12f686bab87f4251a8cf539faedb312a.md: Unknown error 2 (406): Not Acceptable!

Not Acceptable!

An appropriate representation of the requested resource could not be found on this server. This error was generated by Mod_Security.

Is mod_security on server side or within Joplin?

You didn’t say what error you got. If it’s 406, you need to configure your server so that it doesn’t throw this error. Maybe disable mod_security if it’s the culprit.

In practice, this error is very rarely used. Instead of responding using this error code, which would be cryptic for the end user and difficult to fix, servers ignore the relevant header and serve an actual page to the user. It is assumed that even if the user won’t be completely happy, they will prefer this to an error code.

https://developer.mozilla.org/en-US/docs/Web/HTTP/Status/406

I am able to use the Android client without issue but the linux client reports this same error when I try and Synchronize. I have checked and double checked that there were no typos. My install of NextCloud is hosted on HostGator.

Completed: 23/09/2019 19:58

Last error: Error: PROPFIND 824a1c33d6544c68b953556a6bba7783.md: Unknown error 2 (406): Not Acceptable!

Not Acceptable!

An appropriate representation of the requested resource could not be found on this server. This error was generated by Mod_Security.

Most likely a misconfigured server: either remove mod_security or configure it to allow the PROPFIND method.