Linux Mint - Updating Joplin?

I'm running Joplin 2.3.5 (prod, linux) on Linux Mint 20.2.
When I check for updates in Joplin, it says v2.4.2 is available.
And when I run the command line wget -O - https://raw.githubusercontent.com/laurent22/joplin/dev/Joplin_install_and_update.sh | bash, I get this message

You already have the latest version 2.3.5 installed.

I'm relatively new to Linux, so am I missing something in the update process ?
Thanks.

2.4.2 is a pre-release, the script only pull proper releases. I think there was a flag to make it get pre-releases as well.

Thanks.
So, even if I've checked the option "Get pre-release when checking for updates", it doesn't apply to the Linux version ?

That checkbox (assuming you mean the one in Joplin settings) has nothing to do with the script. It's for downloading updates from Joplin and I don't think this update method works on Linux at all.

You need to pass in --prerelease to the script to get pre-release versions.

Ok, I've tried various things with this option but no results.
Nevermind, I'll wait for the official release !
Thanks.

You can download the pre-release from here: Release v2.4.2 · laurent22/joplin · GitHub

Then move it to your .joplin folder under your home folder and enable execution as a program. Worked for me.

Yes, that's what I did but for some reason, Joplin didn't start anymore after that. I'll try again tomorrow.

Double check that it is enabled to run as a program. If not, it will not run and nothing will happen when you double-click on it. Also if you have set up a link to run it, make sure the link has the right name in it.

That was it... I have some kind of a mess in my links, totally forgot this.
Everthing's fine now, running 2.4.3.

Thanks guys for your time.

I have my link(s) set to access "joplin.appimage" and when I manually download a new version I change the name to that.

@bertradio and @blank I wanted to download the last prerelease version in Linux (ubuntu 20.04), using wget -O - https://raw.githubusercontent.com/laurent22/joplin/dev/Joplin_install_and_update.sh | bash and adding a --prerelease in the script, but nothing happened. I do not know why.
To avoid the same manual downloading, enabling executing file as a program, etc, as you described. I have copied the script you find in https://raw.githubusercontent.com/laurent22/joplin/dev/Joplin_install_and_update.sh paste in a local bash script and running it adding --prerelease and this script can check and install the latest prerelease version without any file manipulation.

Did you try with:

wget -O - https://raw.githubusercontent.com/laurent22/joplin/master/Joplin_install_and_update.sh | bash -s -- --prerelease

Ah ! This syntax seems to work. Thanks.
I'm also using a bash script for the update, and I didnt know where to put the --prerelease thing. I'll see at the next prerelease how it goes.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.