Home / GitHub Page

Joplin terminal | need help by installing

Hi there,
i tried to installed joplin terminal like here (https://joplinapp.org/terminal/) on my debian raspberry pi.

node -v gives: v10.15.2

root@batman(~):NPM_CONFIG_PREFIX=~/.joplin-bin npm install -g joplin
npm WARN deprecated left-pad@1.3.0: use String.prototype.padStart()
/root/.joplin-bin/bin/joplin -> /root/.joplin-bin/lib/node_modules/joplin/main.js

> sharp@0.23.4 install /root/.joplin-bin/lib/node_modules/joplin/node_modules/sharp
> (node install/libvips && node install/dll-copy && prebuild-install) || (node-gyp rebuild && node install/dll-copy)

internal/modules/cjs/loader.js:583
    throw err;
    ^

Error: Cannot find module '/root/.joplin-bin/lib/node_modules/joplin/node_modules/sharp/install/libvips'
    at Function.Module._resolveFilename (internal/modules/cjs/loader.js:581:15)
    at Function.Module._load (internal/modules/cjs/loader.js:507:25)
    at Function.Module.runMain (internal/modules/cjs/loader.js:742:12)
    at startup (internal/bootstrap/node.js:283:19)
    at bootstrapNodeJSCore (internal/bootstrap/node.js:743:3)
gyp WARN EACCES current user ("nobody") does not have permission to access the dev dir "/root/.cache/node-gyp/10.15.2"
gyp WARN EACCES attempting to reinstall using temporary dev dir "/root/.joplin-bin/lib/node_modules/joplin/node_modules/sharp/.node-gyp"
gyp WARN install got an error, rolling back install
gyp WARN install got an error, rolling back install
gyp ERR! configure error 
gyp ERR! stack Error: EACCES: permission denied, stat '/root/.joplin-bin/lib/node_modules/joplin/node_modules/sharp/.node-gyp/10.15.2'
gyp ERR! System Linux 4.19.75-v7l+
gyp ERR! command "/usr/bin/node" "/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
gyp ERR! cwd /root/.joplin-bin/lib/node_modules/joplin/node_modules/sharp
gyp ERR! node -v v10.15.2
gyp ERR! node-gyp -v v5.0.5
gyp ERR! not ok 
npm WARN markdown-it-toc-done-right@4.1.0 requires a peer of markdown-it@^10.0.0 but none is installed. You must install peer dependencies yourself.

npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! sharp@0.23.4 install: `(node install/libvips && node install/dll-copy && prebuild-install) || (node-gyp rebuild && node install/dll-copy)`
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the sharp@0.23.4 install script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     /root/.npm/_logs/2020-01-27T20_21_53_330Z-debug.log

Can someone help me please?
I need the E-Mail Gateway in Joplin.

Thx a lot!

You can fix this with using --unsafe-perm while installing. It has to do with the default user being set to ‘nobody’ and you are using the root user.

So you can install using:
npm install -g --unsafe-perm joplin

If you want some more background on the error or want another solution you can find them here:

1 Like

Thanks @2343455teasdfasdfsad !!! the install runs long but that worked.
I can now run sucessfully /root/.npm-global/bin/joplin

Also a systemwide call works now by the help of:
sudo ln -s /root/.npm-global/bin/joplin /bin/joplin