Joplin syncs only a fraction of the files

after upgrading from some older version to 2.4.12 (Windows) my structure is missing and only a fraction of my Notes still exists. After manually importing the directory they have no usable structure or title anymore. For example:


id: c4bbb7c8f50a9e0f7a307231892a3cad
mime: application/octet-stream
filename: camera_sample.card
created_time: 2020-04-06T07:46:30.566Z
updated_time: 2020-04-06T07:46:30.566Z
user_created_time: 2020-04-06T07:46:30.566Z
user_updated_time: 2020-04-06T07:46:30.566Z
encryption_applied: 0
encryption_blob_encrypted: 0
size: 4296
is_shared: 0
type_: 4

Is it possible to ingress all files and relink them with attachments as well?

Is it possible that it is some sort of version mismatch? Is there a documentation on how the format changed between different versions? Then I could apply an older version and test it.

It looks like you have importet the data from the sync target, this will not work!

You have to setup a sync with this folder.
But make first a backup of the folder, before the data gets messed up.

Thank you very much, I tried syncing before but only a fraction of the files were loaded so I tried manual import. Which leads to the problem.

Clean install of the now newest version (2.5.10), complete removal of all old files, and resyncing with the (copied) sync directories lead to the syncing off all missing files.

In addition I used the "Remove local files and sync from target" in the sync option -> advanced menu

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.