Joplin server latest : postgres-db docker image down


I run Joplin server on a NAS with Docker. I wanted to update the server. I used this docker-compose :

version: '3'

        image: postgres:latest # Download latest postgres image
        container_name: postgres-db # Here you can give the container a name of your liking 
        restart: unless-stopped # Restart if not stopped manually
            - /volume1/docker/joplin/joplin-data:/var/lib/postgresql/data # Make database files persistent. Otherwise your data is lost when the container is destroyed.
            - APP_PORT=22300 # Specify port joplin-server is reachable at
            - POSTGRES_PASSWORD=******* # Specify database password
            - POSTGRES_USER=****** # Specify database user
            - POSTGRES_DB=******* # Specify database name
        image: joplin/server:latest # Download joplin-server image latest
        container_name: joplin-server
            - db
            - "22300:22300" # Expose internal port to LAN
        restart: unless-stopped
            - APP_BASE_URL=https://joplin.********.** # If you do not want to expose joplin-server to the internet use your LAN-IP and port
            - DB_CLIENT=pg
            - POSTGRES_PASSWORD=********* # Must be the same as above
            - POSTGRES_DATABASE=********* # Must be the same as above
            - POSTGRES_USER=********** # Must be the same as above
            - POSTGRES_PORT=5432 # Postgres internal port
            - POSTGRES_HOST=db

Until this update, I was running the 2.2.5 beta.

I now have a problem with postgres-db docker image : it never stops to restart. I have no clue why. Any Idea ?

I solved my problem.

Instead of latest version of postgres-db, I put 13.1, as written in this example :

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.