How can I create the notebook "Conflicts"

I don’t know how, but I deleted the notebook “Conflicts” on my laptop (actually in german: Konflikte). I tried to recreate it but I get an error message: this name ist reserved. What can I do?

It will be recreated automatically as soon as another conflict occurs.

Thanks! I added a sync with an additional computer and suddenly appeared the notebook.

To elaborate what tessus said… When you edit a note, Joplin marks that note as dirty, i.e. containing unsychronised changes. At that time the changes exist only in a local copy of the note. At some later point the synchronisation process begins, and it saves all dirty-marked notes to the permanent storage (Dropbox or whatever you have selected).

When you launch Joplin on another device, the synchronisation process checks whether there are any changes in the permanent storage, that are not in the local copies of the notes. But neither beginning of this check is immediate upon the launch.

So there is a possibility, that you begin to edit a note before its changes are propagated from another device to the one you're using currently. To solve this conflict Joplin chooses the less intrusive way. You can keep editing the note at hand as if nothing were wrong, but at the same time it puts the unsynchronised, previous version of the note in the conflict folder. So you loose no edits, but can yourself merge the changes from the previous version into the new one.

Once you gone through the notes in the conflict folder, you can trash the folder. It will be automatically recreated, if you were once again too fast to edit a note :slight_smile:


Thanks for the explanation!

Can we clarify the sync mechanism, please? I’ve lost a few posts and I think I know why.

You make a change on a local device and that’s marked dirty. If you don’t synchronise, then the “permanent storage” doesn’t know there’s a change.

Luckily I’ve been trying Joplin out on stuff I don’t mind losing. Like shopping lists.

I have deleted my conflicts folder but I’ve lost entries on the shopping list on an android device when I’d made changes on both a linux machine and an iOS device. I’m not sure which devices auto-sync; is that a setting? I see the iOS Joplin has a disk icon that disappears so it is auto saving but that’s not auto-syncing. Is it?

Anyway. As I’d left the change to the shopping list on the Android device until after I’d made changes and synchronised on other devices, it looks like my local note is out of date and it silently got overwritten. Not conflict folder was recreated and no conflicting pair of shopping list files.

I’ll try and recreate the situation but thought I’d put this here in case some other people are finding problems.

P.s. I’m testing this very carefully because I have over 2000 notes in my paid-for evernote instance and it gets used on every mobile OS and every desktop OS as well as each browser. Joplin is alread better than evernote because it is native Markdown.

Joplin will auto-save, then auto-sync as soon as possible but those are two different actions, and it’s possible that the note have been saved, but not synced yet. In general, on mobile especially, it’s good to run a manual sync from time to time to make sure everything is up to date. On desktop it’s less of an issue because sync will happen in the background (as long as you leave it running in the tray).

But otherwise there’s no known bug in the sync mechanism, and at worst if you forget to sync it should move the notes to the conflict notebook.

I have the same issue, but the solution doesn't work for me.

I had some conflicts, so I solved these and deleted the folder on my desktop. I thought I don't need it anymore, and it will appear when I have new conflicts. But it doesn't appear. I tried to create a new notebook "Conflicts", but I get an error: Notebooks cannot be named "Conflicts", which is a reserved title. On my mobile phone, there is the folder "Conflicts" with some entries. I also changed the language and created a folder "Conflicts". It worked even if I change the language back into English. Then I had two folders on mobile and one (not the right one) on desktop.

I updated Joplin, but nothing changed.

I reinstalled it (maybe not properly because after a new install all my notes were there without any action), but it remains the same.

Do you have any other idea how can I solve this issue?