Hide button switch Markdown and WYSIWYG

I honestly don't see why

div.editor-toolbar div button {
	 display: none !important;

Wouldn't target that button in markdown mode, you can see in the html that button is a child of a div which is a child of div.editor-toolbar.

oh well
Thanks for your help, much appreciated
I will just have to live with it then cause if you cant see why its not working, there is little hope I will be able too :rofl:

Honestly baffled, this is what I expect to see:

If you want to try one final thing you can check if it works in the dev env.

Go Help > Copy dev mode command to clipboard then paste that in either a terminal or whatever thing openbox might have like dmenu. It will open a new Joplin instance unrelated to your main one with its own profile in .config/joplindev-deskop which will have no notes, no plugins, no nothing.

If it doesn't work there then I think your Joplin install is haunted.

:ghost: :ghost: :ghost: :ghost: :ghost: :ghost:

If I want to clean install which folders do I also have to delete (tried uninstalling and reinstalling but all my configs were the same (dark, sync etc)

Is it just the Joplin, Joplin-desktop, and now joplindev-desktop folders in ~/.config?

You have got me invested enough that I'm putting openbox onto that AL vm...

Basically yes, Joplin is the cache but holds no config data, joplin-desktop and joplindev-desktop are your config folders, removing those should "reset" everything fully.

1 Like


I uninstalled, deleted my configs, and reinstalled and the first thing I did was to cut and paste from your post above into my new userchrome.css

I was very careful as my system currently opens the css file from the Joplin menu in LibreOffice Writer
Although I always save as text, I just shut LO straight after it was opened by the Joplin menu - thus generating the css file, and then edified the css in xed

Now to get back to where I was with sync and dark and a keybind I changed (indent)

All appearance, pluggins (just 'Menu items, Shortcuts Toolbar icons' and 'Simple Backup'), markup, keyboard shortcuts and webclipper done and still no button :smiley:

Fully synced and exactly how I like it

Toggle Editor Button still not there

Its solved :white_check_mark:

No idea why it happened
Maybe installing and uninstalling plugins?
Just guessing
Anyways, a clean install was required

Thanks for help and apologies for hijacking thread :blush:

Well that was an adventure, I'm still puzzled how it could have happened in the first place unless it was something weird in the PKGBUILD.

1 Like

ENHANCEMENT REQUEST: Make hiding the WYSIWYG toggle a simple toggle option in the config menus.

I had no issue hiding it with CSS (I believe I had to restart Joplin though). My biggest issue was finding the CSS snippet that enabled this. Note, I can also understand the position that Laurent may not want the ability to hide that button such an easy thing to do, but ... yeah, I do. :slight_smile: Stick it in the advanced settings section. Side note: I think most non-default settings need to be moved into an "advanced" set of sections since the config menus are getting ... a bit too crazy.

Anyway. @laurent, that's my request. Thanks! -todd

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.