Downloading Resources in Linux

UPDATE: 7/10/2019 - Turning on Encryption fixes this issue – or is a good workaround. Probably should have been using it all along.

Joplin Version: 1.0.160 (prod,linux)
OS: Ubuntu 18.04.2 LTS (Xubuntu XFCE 4.12)

  • Used the script to install
  • WebDAV on Fastmail for Sync


Important to note that I use Joplin on two Windows 10 Pc, my iPhone and my iPad as well. NO Issues there.

Howeve, I’ve been playing with Linux lately on some old computers and I can’t seem to get Joplin to work correctly as far as the resources are concerned.

After the install, I enter the WebDAV URL and credentials. Joplin proceeds to sync. The sync of the notes all works fine, but the resources don’t really come through. I have 3792 resources, but as the initial sync happens is shows something like 3/25000… It will download about 40 or so resources (I can see them in /home//.config/joplin-desktop/resources/ folder). And then it seems to be stuck.

That is with the ALWAYS setting on resources.

The debug log (flags set) doesn’t show any errors. In fact, when the sync finishes it’s as if Joplin thinks it downloaded everything. Under Synchronization Status is looks just like it does on my other machines:

Note: 976/976
Folder: 72/72
Resource: 3792/3792
Tag: 0/0
NoteTag: 0/0
MasterKey: 0/0
Revision: 140/140
Total: 4980/4980

I’ve deleted the “joplin-desktop” folder and started over. This time with resources set to MANUAL.

Sync completes as expected.

When I click on a resource I get the hourglass icon. I can see the resources is downloaded to the folder, but then Joplin doesn’t display it. If I click on another note and come back, then it will show it. It does this with all resources, at least the ones I have, JPGs and PDFs.

If I were to click on one resource, I get the hourglass. If i click on the next right away, nothing happens to that icon. If I click on another note and come back, the first resource shows, but the second one it’s as if I never clicked on it. Eventually it will show up, but not always. Sometimes I have to repeat the process.

Every time I click on a resource icon, whether it changes to hourglass or not, the “Dowloading Resource” message increases by one. I can keep clicking and the number will continue to increase.

I hope this is enough information.

Thanks for taking a look at this!

Under Tools->General Options in the Synchronization section there is an option “Attachment download behaviour”. What is this set to?

Thanks for chiming in. Notice I’ve tried it with it set to Always and then with it set to Manual. The manual might give a better clue.