Deleting notes doesnt actually delete them?

win10 pro
joplin 1.0.233 portable

so ive tried using the web clipper on chrome and download some random page. note looks good. i deleted it and synced again

i have like 4 notes and the sync folder is full of files (i guess that’s normal… with note revisions etc), but the images from the note i deleted are still in .resource folder using up space

am i doing something wrong?

Short answer because I’m on my phone, Joplin only performs cleanup occasionally to prevent lost resources. This sometimes doesn’t work perfectly, but for the most part you just need to wait and they’ll be cleaned up.

Feel free to search the forum’s for more detailed information, this question comes up a lot so you shouldn’t have much trouble finding lots of info.

Ok thanks

I’ve tried search with delete/deletion/trash and found nothing.
Also tried the faq.

If the question comes out a lot maybe it should be in the faq.

Care to link me some detailed information? Thank you

Below are some useful threads (and a github issue) that I found searching the forums.
Just FYI I found these by searching the term "deleting notes", below is the first thread to come up and I clicked through it to get the rest.

Yeah I found the first one. Doesn't really offer any solution and it's a 1 year old post. Besides scripts and messing with the database, no clear/easy solution. :frowning:

From what I read, deleted resources get cleaned up 24h later and it's a bug that happens sometimes which prevents this from happening. Right?

I guess all a noob like me can do is wait for an official fix lol