Webclipper not working anymore

Im using the webclipper on the latest version of Firefox on Win10.
Since U`updating Joplin to 2.1.7. the webclipper is not working anymore.

What to do?

Unfortunately the newer version of Joplin doesn't work with the older version of the clipper, for security reasons. I've released the new clipper on the Firefox and Chrome store but it might take some time before they're available.


A post was split to a new topic: Can't get joplin server to work

Same issue here.

I installed Joplin for the first time this morning..


Hi Laurent,

Do you know if it will be a long process ?

New user

Should be fine on Chrome now, if not let me know. The Firefox one was buggy so I've published a fixed one which should be available soon.

Was the buggy Firefox version 2.1.1? I ask as that one cannot be authorised using v2.1.7 desktop. It seems to ignore the authorisation.

EDIT: Ignore that. I just looked at Joplin releases and saw that there is a clipper 2.1.2 which seems to answer my question :slight_smile:

I have updated to 2.1.2 on Firefox 89.02 This is what I get when I try to clip:

I have restarted FireFox. I have restarted Joplin and it is running. I'm on Windows.

Joplin 2.0.11 (prod, win32)
Profile Version: 39
Revision: 981b1d845

Before upgrading to 2.1.2 it worked fine.

This was the Firefox message for clipper 2.1.1 (which it seems was buggy (but more informative))


Note that Joplin v2.1.x is needed.


1 Like

Oh, gosh. I just updated. I didn't realize that there was already another important upgrade.

I'm on limited data. Do we know for sure that upgrading to 2.1.x is going to work?

Confirming that it works on Joplin client v2.1.7

Anyone tried with Joplin desktop 2.1.7 and the Chrome extension? Is it working for you?

Are we supposed to remove the old one and install the new one in Firefox?

yes! after updating joplin to 2.1.7 the clipper in Chrome works again.

There's anotehr issue, but I will open it on gh.

It appears that the newest web clipper doesn't work if I'm still running Joplin 1.8.5. Is that expected?

Yes, for security reasons the clipper now requests permission to access Joplin data, and the old versions of Joplin don't have the API to authorise the clipper so they cannot work.

1 Like

This happened to me but I DIDN"T CHANGE ANYTHING - has there been some kind of background update againast my wishes?
I generally need to keep my environment very static.

It appears that firefox may have auto-updated the web-clipper - how do I go back to the old one?