Home / GitHub Page

Warning for synchronising with Onedrive business

I started using Joplin on LInux today and tried synchronising with a Onedrive account, but nothing happened: no warning or failure message, it just didn’t synchronise.

So I enabled debugging mode, and immediately got a message warning me that synchronising using a Onedrive Business account is not possible (actually my account is a student account at at a university, but I’m guessing that it’s the same issue). I then tried switching to my personal Onedrive account, and the sync went fine.

This seems like a bit of a bug, for me: the warning about the Onedrive account should happen whether you’re in debug mode or not. Let me know if I should post this in the Github Issues list for Joplin instead.

Update: the failed synchronization happened to me twice, on two different Linux machines, with the same lack of error messages/warnings. But the second time I logged in to the other machine, it gave me the warning about Onedrive business accounts without having to switch to debug mode first.

Yes, this seems like a genuine bug to me and Joplin should show you some sort of error message.

Please open an issue on github and attach the debug.log as well.

Yes it should indeed show a message box, even in non-debug mode.

Alright, I’ll do that.

It seems that this did not happen yet at least I don’t get notifications, that I am trying to connect to OneDrive Business and that this is not supported.