# Syncronization with nexcloud 

**URL:** <https://discourse.joplinapp.org/t/syncronization-with-nexcloud/2362>\
**Category:** Support\
**Created:** [13 May 2019 11:19 UTC](https://discourse.joplinapp.org/t/syncronization-with-nexcloud/2362 "2019-05-13T11:19:35Z")\
**Posts on this page:** 16\
**Page:** 1

<div class="post-metadata">

**Author:** ![luks42](https://yyz2.discourse-cdn.com/flex028/user_avatar/discourse.joplinapp.org/luks42/32/920_2.png) [@luks42](https://discourse.joplinapp.org/u/luks42)\
**Post date:** [13 May 2019 11:19 UTC](https://discourse.joplinapp.org/t/syncronization-with-nexcloud/2362/1 "2019-05-13T11:19:35Z")

</div>

Hello,  
I configured joplin on my android smartphone and my linux PC and it’s work great but now I’m trying to set up on my windows PC and I can’t connect. How to do this ?  
the error :  
`request to https://XXXXX/remote.php/webdav/xxxx/ failed, reason: connect ETIMEDOUT 213.186.33.40:443 (Code ETIMEDOUT)`  
Thank you in advance

---

<div class="post-metadata">

**Author:** ![foxmask](https://avatars.discourse-cdn.com/v4/letter/f/c68b51/32.png) [@foxmask](https://discourse.joplinapp.org/u/foxmask)\
**Post date:** [13 May 2019 11:20 UTC](https://discourse.joplinapp.org/t/syncronization-with-nexcloud/2362/2 "2019-05-13T11:20:30Z")

</div>

hi and welcome  
which joplin version do you use ?

---

<div class="post-metadata">

**Author:** ![luks42](https://yyz2.discourse-cdn.com/flex028/user_avatar/discourse.joplinapp.org/luks42/32/920_2.png) [@luks42](https://discourse.joplinapp.org/u/luks42)\
**Post date:** [13 May 2019 11:30 UTC](https://discourse.joplinapp.org/t/syncronization-with-nexcloud/2362/3 "2019-05-13T11:30:30Z")

</div>

I use Joplin 1.0.151 (win32)

---

<div class="post-metadata">

**Author:** ![luks42](https://yyz2.discourse-cdn.com/flex028/user_avatar/discourse.joplinapp.org/luks42/32/920_2.png) [@luks42](https://discourse.joplinapp.org/u/luks42)\
**Post date:** [13 May 2019 11:32 UTC](https://discourse.joplinapp.org/t/syncronization-with-nexcloud/2362/4 "2019-05-13T11:32:34Z")

</div>

The log file :

```
2019-05-13 11:53:42: "La synchronisation est déjà en cours. État : in_progress"
2019-05-13 11:58:42: "RevisionService::maintenance: Starting..."
2019-05-13 11:58:42: "RevisionService::maintenance: Service is enabled"
2019-05-13 11:58:42: "Running background sync on timer..."
2019-05-13 11:58:42: "Scheduling sync operation..."
2019-05-13 11:58:42: "Preparing scheduled sync"
2019-05-13 11:58:42: "Starting scheduled sync"
2019-05-13 11:58:42: "RevisionService::collectRevisions: Created revisions for 0 notes"
2019-05-13 11:58:42: "RevisionService::maintenance: Done in 114ms"
2019-05-13 12:00:38: "FetchError: request to https://XXXXXX.XXX/remote.php/webdav/Joplin/.sync/ failed, reason: connect ETIMEDOUT 
Code: ETIMEDOUT    
FetchError: request to https://XXXXXX.XXX/remote.php/webdav/Joplin/.sync/ failed, reason: connect ETIMEDOUT
at ClientRequest.<anonymous> (C:\Users\lucas.rivoirard\AppData\Local\Programs\Joplin\resources\app.asar\node_modules\node-fetch\index.js:133:11)
at ClientRequest.emit (events.js:182:13)
at TLSSocket.socketErrorListener (_http_client.js:391:9)
at TLSSocket.emit (events.js:182:13)
at emitErrorNT (internal/streams/destroy.js:82:8)
at emitErrorAndCloseNT (internal/streams/destroy.js:50:3)
at process._tickCallback (internal/process/next_tick.js:63:19)"
2019-05-13 12:00:38: "Operations completed: "
```

---

<div class="post-metadata">

**Author:** ![sciurius](https://yyz2.discourse-cdn.com/flex028/user_avatar/discourse.joplinapp.org/sciurius/32/132_2.png) [@sciurius](https://discourse.joplinapp.org/u/sciurius)\
**Post date:** [13 May 2019 14:41 UTC](https://discourse.joplinapp.org/t/syncronization-with-nexcloud/2362/5 "2019-05-13T14:41:11Z")

</div>

If you type the exact url in a web browser, can it connect?

```auto
https://XXXXXX.XXX/remote.php/webdav/Joplin/.sync/

```

---

<div class="post-metadata">

**Author:** ![luks42](https://yyz2.discourse-cdn.com/flex028/user_avatar/discourse.joplinapp.org/luks42/32/920_2.png) [@luks42](https://discourse.joplinapp.org/u/luks42)\
**Post date:** [13 May 2019 18:40 UTC](https://discourse.joplinapp.org/t/syncronization-with-nexcloud/2362/6 "2019-05-13T18:40:03Z")

</div>

Yes I can connect in a web browser but I have this message :

```
This is the WebDAV interface. It can only be accessed by WebDAV clients such as the Nextcloud desktop sync client.
```

---

<div class="post-metadata">

**Author:** ![tessus](https://yyz2.discourse-cdn.com/flex028/user_avatar/discourse.joplinapp.org/tessus/32/13_2.png) [@tessus](https://discourse.joplinapp.org/u/tessus)\
**Post date:** [13 May 2019 23:06 UTC](https://discourse.joplinapp.org/t/syncronization-with-nexcloud/2362/7 "2019-05-13T23:06:03Z")

</div>

> [@luks42](#):
>
> Yes I can connect in a web browser

Did you do this on the Windows machine? The reason I ask is that the error message you received hints that the connectdion to that server or address is blocked. Why would you receive a timeout otherwise?  
IMO a personal firewall or Windows blocks something.

---

<div class="post-metadata">

**Author:** ![luks42](https://yyz2.discourse-cdn.com/flex028/user_avatar/discourse.joplinapp.org/luks42/32/920_2.png) [@luks42](https://discourse.joplinapp.org/u/luks42)\
**Post date:** [14 May 2019 06:50 UTC](https://discourse.joplinapp.org/t/syncronization-with-nexcloud/2362/8 "2019-05-14T06:50:51Z")

</div>

Yes I did it on my windows machine and it works.  
So I don’t understand why it doesn’t work on Joplin application …

---

<div class="post-metadata">

**Author:** ![tessus](https://yyz2.discourse-cdn.com/flex028/user_avatar/discourse.joplinapp.org/tessus/32/13_2.png) [@tessus](https://discourse.joplinapp.org/u/tessus)\
**Post date:** [14 May 2019 10:57 UTC](https://discourse.joplinapp.org/t/syncronization-with-nexcloud/2362/9 "2019-05-14T10:57:22Z")

</div>

> [@luks42](#):
>
> So I don’t understand why it doesn’t work on Joplin application …

Right, I'm not sure I understand this either. On macOS I use LittleSnitch, where I have to allow applications to connect to remote resources. Maybe you use something similar on Windows.

But I believe there was a sync issue with 1.0.151. Could you try with [1.0.152](https://github.com/laurent22/joplin/releases/tag/v1.0.152)?

---

<div class="post-metadata">

**Author:** ![tessus](https://yyz2.discourse-cdn.com/flex028/user_avatar/discourse.joplinapp.org/tessus/32/13_2.png) [@tessus](https://discourse.joplinapp.org/u/tessus)\
**Post date:** [14 May 2019 12:10 UTC](https://discourse.joplinapp.org/t/syncronization-with-nexcloud/2362/11 "2019-05-14T12:10:48Z")

</div>

@laurent Do you have some more insights? I am really not the person to help with Windows issues. What would be a reason for a `ETIMEDOUT` error code.

P.S.: Maybe I should setup Windows in a VM and start looking into Windows again.(I don’t even know how to buy a Windows copy.) The last time I installed Windows was NT Server 3.1 or 3.51.

---

<div class="post-metadata">

**Author:** ![laurent](https://avatars.discourse-cdn.com/v4/letter/l/ce7236/32.png) [@laurent](https://discourse.joplinapp.org/u/laurent)\
**Post date:** [14 May 2019 12:22 UTC](https://discourse.joplinapp.org/t/syncronization-with-nexcloud/2362/12 "2019-05-14T12:22:11Z")

</div>

I don’t know but it’s not a bug in Joplin. It’s just a timeout probably due to config error, firewall like you said, or something else.

---

<div class="post-metadata">

**Author:** ![sciurius](https://yyz2.discourse-cdn.com/flex028/user_avatar/discourse.joplinapp.org/sciurius/32/132_2.png) [@sciurius](https://discourse.joplinapp.org/u/sciurius)\
**Post date:** [14 May 2019 19:26 UTC](https://discourse.joplinapp.org/t/syncronization-with-nexcloud/2362/13 "2019-05-14T19:26:21Z")

</div>

Maybe a problem with cert validation?

---

<div class="post-metadata">

**Author:** ![luks42](https://yyz2.discourse-cdn.com/flex028/user_avatar/discourse.joplinapp.org/luks42/32/920_2.png) [@luks42](https://discourse.joplinapp.org/u/luks42)\
**Post date:** [15 May 2019 08:01 UTC](https://discourse.joplinapp.org/t/syncronization-with-nexcloud/2362/14 "2019-05-15T08:01:20Z")

</div>

How can I verify that there is a certificate problem?

---

<div class="post-metadata">

**Author:** ![sciurius](https://yyz2.discourse-cdn.com/flex028/user_avatar/discourse.joplinapp.org/sciurius/32/132_2.png) [@sciurius](https://discourse.joplinapp.org/u/sciurius)\
**Post date:** [16 May 2019 20:07 UTC](https://discourse.joplinapp.org/t/syncronization-with-nexcloud/2362/15 "2019-05-16T20:07:25Z")

</div>

Can you try a non-https url?

Instead of

```auto
https://myserver/remote.php/webdav/...

```

use

```auto
http://myserver/remote.php/webdav/...

```

---

<div class="post-metadata">

**Author:** ![luks42](https://yyz2.discourse-cdn.com/flex028/user_avatar/discourse.joplinapp.org/luks42/32/920_2.png) [@luks42](https://discourse.joplinapp.org/u/luks42)\
**Post date:** [17 May 2019 07:42 UTC](https://discourse.joplinapp.org/t/syncronization-with-nexcloud/2362/16 "2019-05-17T07:42:35Z")

</div>

I have exactly the same error with non-https link 😥

---

<div class="post-metadata">

**Author:** ![zblesk](https://yyz2.discourse-cdn.com/flex028/user_avatar/discourse.joplinapp.org/zblesk/32/11_2.png) [@zblesk](https://discourse.joplinapp.org/u/zblesk)\
**Post date:** [17 May 2019 11:37 UTC](https://discourse.joplinapp.org/t/syncronization-with-nexcloud/2362/17 "2019-05-17T11:37:41Z")

</div>

Maybe check your proxy settings? If your computer is at work, there’s a good chance some proxy is involved somewhere.
