Pre-release 1.4 is now available for testing (Updated 23/11/20)

Yes, an orange banner will be displayed

How do you open the resource? Is it from the app or via the API?

Through the Joplin app, here is a demo GIF @laurent


log.txt (11.1 KB)

Thanks, I'll check that again. Maybe it's Notepad saving the file in a strange way?

I tested VSCode and the results were the same. I suspect it is related to Joplin's file listener, but I did not conduct in-depth testing. I will enter the database level when I have time.

Regarding this point, I finally used the split screen of Windows to redisplay it. It shouldn't be the problem of Joplin itself. It may be that I accidentally moved the window out of the window or other invisible unknowns.

That will be fixed in the next release. It seems Chokidar no longer normalize paths, so the app couldn't map the watched path to the resource anymore on Windows.

v1.4.12 is now available:

Breaking Changes:

  • If you use the Clipper API, please note that there are a few breaking changes in this version. See this link for more information:
  • Plugins: now returns an object instead of the button ID that was clicked. So for example instead of getting just "ok", you will get { "id": "ok" }. This is to allow adding form data to that object.


The following features are deprecated. It will still work for now but please update your code:

  • Plugins: All create() functions under joplin.views now take a viewId as a first parameter.
  • Plugins: MenuItemLocation.Context is deprecated and is now an alias for MenuItemLocation.NoteListContextMenu
  • Plugins: The app_min_version manifest property is now required. If not provided it will assume v14.
  • Plugins: The id manifest property is now required. If not set, it will be the plugin filename or directory.

Plugin doc has been updated with some info about the development process.

  • Improved: Partially reverts #3975 (link rendering)
  • Improved: Plugins: Provides selected notes when triggering a command from the note list context menu
  • Improved: Plugins: Use plugin ID as filename
  • Fixed: Fix handling of new line escaping when using external edit
  • Fixed: Fixed Markdown rendering when code highlighting is disabled
  • Fixed: Fixed importing certain ENEX files that contain invalid dates
  • Fixed: Fixed links imported from ENEX as HTML (#4119)
  • Fixed: Fixed resource watching on Windows
  • Fixed: Plugins: Fixed issue with toolbar button key not being unique

  • Fixed: Api: Fix note and resource association end points
  • Fixed: Display note count for conflict folder, and display notes even if they are completed to-dos (#3997)
  • Fixed: Fix crash due to React when trying to upgrade sync target (#4098)
  • Fixed: Fix drag and drop behaviour to "copy" instead of "move" (#4031 by @CalebJohn)
  • Fixed: Fix handling of certain keys in shortcut editor (#4022 by Helmut K. C. Tessarek)
  • Fixed: Fix size of search bar area when notebook is empty
  • Fixed: Fixed inconsistent note list state when using search (#3904)
  • Fixed: Fixed issue when a newly created note would be automatically moved to the wrong folder on save (#4038)
  • Fixed: Fixed issue with note being saved after word has been replaced by spell checker
  • Fixed: Fixed note list overflow when resized very small
  • Fixed: Fixed text editor button tooltips
  • Fixed: Plugins: Fix crash when path includes trailing slash
  • Fixed: Plugins: Fixed issue with dialog being empty in some cases
  • Fixed: Prevent log from filling up when certain external editors trigger many watch events (#4011)
  • Fixed: Regression: Fix application name
  • Fixed: Regression: Fix exporting to HTML and PDF
  • Fixed: Regression: Fixed external edit file watching
  • Fixed: Resource links could not be opened from Rich Text editor on Linux (#4073)
  • Fixed: Tags could not be selected in some cases (#3876)
  • Improved: Allow exporting conflict notes (#4095)
  • Improved: Allow lowercase filters when doing search
  • Improved: Api: Always include 'has_more' field for paginated data
  • Improved: Api: Make sure pagination sort options are respected for search and other requests
  • Improved: Attempt to fix Outlook drag and drop on Markdown editor (#4093 by @CalebJohn)
  • Improved: Change Markdown rendering to align with CommonMark spec (#3839)
  • Improved: Disable spell checker on config and search input fields
  • Improved: Disabled the auto update option in linux (#4102) (#4096 by Anshuman Pandey)
  • Improved: Make Markdown editor selection more visible in Dark mode
  • Improved: Optimized resizing window
  • Improved: Plugins: Allow retrieving form values from dialogs
  • Improved: Plugins: Force plugin devtool dialog to be detached
  • Improved: Plugins: Make sure "replaceSelection" command can be undone in Rich Text editor
  • Improved: Plugins: Rename command "editorSetText" to "editor.setText"
  • Improved: Prevent lines from shifting in Markdown Editor when Scrollbar appears (#4110 by @CalebJohn)
  • Improved: Put title bar and toolbar button over two lines when window size is below 800px
  • Improved: Refresh sidebar and notes when moving note outside of conflict folder
  • Improved: Upgrade to Electron 10
  • New: Add {{bowm}} and {{bows}} - Beginning Of Week (Monday/Sunday) (#4023 by Helmut K. C. Tessarek)
  • New: Add config screen to add, remove or enable, disable plugins
  • New: Add option to toggle spellchecking for the markdown editor (#4109 by @CalebJohn)
  • New: Added toolbar button to switch spell checker language
  • New: Adds spell checker support for Rich Text editor (#3974)
  • New: Allow customising application layout
  • New: Api: Added ability to watch resource file
  • New: Api: Added way to get the notes associated with a resource
  • New: API: Adds ability to paginate data (#3983)
  • New: Plugins: Add command "editorSetText" for desktop app
  • New: Plugins: Add support for editor context menu
  • New: Plugins: Add support for external CodeMirror plugins (#4015 by @CalebJohn)
  • New: Plugins: Add support for JPL archive format
  • New: Plugins: Added command to export folders and notes
  • New: Plugins: Added support app_min_version property and made it required
1 Like

Looks like there's no big issue with this pre-release so far, so I'll probably release it for good this week.

1 Like


I tried out version 1.4 on two computers today. On a Windows 7 64-bit laptop, it works apparently well.

On a Windows 7 32-bit PC, the user interface doesn't show up, but the background processes are active.

Any suggestions?
Thank you.

OS: Windows 7 (32 bits) Service Pack 1 (Build 7601)


Hmm, not sure, we've supported win 32-bit for several years but maybe we're getting to a point where our dependencies are no longer compatible. Without any error it's hard to tell anyway. Perhaps see if you can at least get the console to open.

Hi Laurent,

thank you for responding. I tried the console, but it doesn't respond either. I understand that without more information it is not possible to take an action.

I'm going to do some more tests and if something new comes up I'll let you know.

Thank you.

1 Like

I have been testing the various pre-releases for the RPM builds I support. EL8 suddenly stop building with this error. If anyone has a clue, I'd appreciate it.

[15:45:45] Starting 'electronRebuild'...
Running: "/builddir/build/BUILD/joplin-1.4/joplin-1.4.18/packages/app-desktop/tools/../node_modules/.bin/electron-rebuild"
[15:45:49] 'electronRebuild' errored after 4.57 s
[15:45:49] Error: Command failed: "/builddir/build/BUILD/joplin-1.4/joplin-1.4.18/packages/app-desktop/tools/../node_modules/.bin/electron-rebuild"
- Searching dependency tree
gyp: Undefined variable napi_build_version in binding.gyp while trying to load binding.gyp
✖ Rebuild Failed

Interestingly, older OS versions (EL7 for example, still build fine) as do later (Fedora 31, 32, 33). I had to jump through a few hoops to get OpenSUSE building, but those are building as well now. Only EL8 is causing me fits. I.e., I am test building 8 OS permutations. EL8 is the one failure at this point.

I'm not familiar with this error, but Electron has been upgraded from v8 to v10 and they've changed something to the way they handle native modules, so maybe it's related. Perhaps there are some issues about it on their repo?

I see a similar issue posted here: Npm i fails
I will troubleshoot. I did about a day of digging on this maybe a month ago (whenever 1.4.x first landed) and then I tabled it because I couldn't figure it out. Anyway. Thanks for the response. I'll see what I can do.

UPDATE: I had to enable a a different nodejs (EL and Fedora builds are now "modular" and entire multiple versions of packages are available but you have to enable the specific package sets). I.e., using nodejs:12 instead of nodejs:10 solved this issue. Cheers.

At present, the modification of local attachment resources can be saved normally, but the synchronization is still abnormal, you can view the gif demo @laurent

Joplin 1.4.18 (prod, win32)

For me resource sync is working, and it's not entirely clear what the video is showing. But if it's not syncing it could be some unrelated OneDrive sync issue and for that we'd need the log.

Finally, I saw the content of the synced attachment on another computer, there may be some delay

Would it be useful to un-pin this seeing as it is into 1.5 now?