Home / GitHub Page

Network request failed / Joplin on Android

Update: to me feels similar like the following described earlier:


As it looks android sdk only allows https requests. But when using https requests, there is the problem with the self-signed certificate (openssl). How can I fix this? (as it’s fixed in the desktop version). Or can this be fixed in a new release of the android version? I need joplin sync to work on android otherwise will have to look for alternative.

This is a strange problem to me.
Until end of last week, I could without problems sync between Joplin on Android and my nextcloud.
Then since approx last Monday, the sync does not work any more and I get the “Network request failed” errors

My nextcloud runs on the intranet only, let’s call it my-server with a fixed local IP address (with a fritz box modem/route)

The Nextcould WebDav-URL in Android/Joplin is as follows:
http://my-server/nextcloud/remote.php/webdav/Joplin_Notes

I have a openssl certificate, but I have no redirect from http to https, I’m using apache2 on raspberry. Which means I can access my nextcloud instance both via http and https request. I use https wherever I can, I have basically left the http option (without a redirect) just for the purpose of the android Joplin client because this one obviously does not want to work with self-signed certificates. And running my nextcloud on the intranet on the host my-server will not allow me to create an “official” certificate, as I understand.

From Android device, here is what still works fine even today:

  • accessing nextcloud with the official nextcloud client
  • I can open via android browser the webdav URL stated above which then asks me for a username/password, then tells me the following, which I thinks makes sense as a positive response: “This is the WebDav interface. It can only be accessed by WebDav clients such as Nextcloud desktop sync client.”
  • I was even able to map the webdavn URL mentioned above as a webdav access in a android file explorer (in my case the ES file explorer pro) and I can open files and create new files.

Also to note that Joplin from Windows desktop still works like a charm.

The only “upgrade” I made on nextcloud was a cleanup on the trashbin and the versions (run the occ trashbin:expire and versions_expire). Not creative enough to understand how this would affect Joplin from Android.

So my initial conclusions:

  • The webdav URL mentioned above is accessible from my android device (see above)
  • I do not see any issue with the webdav service (as I can even embed via file explorer on android)

So my final conclusion:
I just have no idea what I can do to solve this problem.
Anyone have an idea? Would be highly appreciated.

This topic is a duplicate of WebDAV not work with last release of Android.

Closing this one. Head over there for all further discussions.

Joplin works with self-signed certs for a while now. It helps reading the documrntation and FAQ.

How can I use self-signed SSL certificates on Android?

If you want to serve using https but can’t or don’t want to use SSL certificates signed by trusted certificate authorities (like “Let’s Encrypt”), it’s possible to generate a custom CA and sign your certificates with it. You can generate the CA and certificates using openssl, but I like to use a tool called mkcert for it’s simplicity. Finally, you have to add your CA certificate to Android settings so that Android can recognize the certificates you signed with your CA as valid (link).