Links to attachments lost

Nope. The rendered note shows the download attachment icon. Clicking that does nothing...

No HTML or so.

And does the resource exist, unencrypted, in your resource directory? Help > Synchronisation status will show you if there are any resources that are downloaded but not decrypted.

Thanks for helping me.

Downloaded and decrypted: 2811
Downloaded and encrypted: 0

Hmm... what to do next?

Was there anything special about the way this note or attachment was created? Do you use any plugin?

This is a very plain note, where I drag the images into; no plugin or html involved. The particular images that are no longer showing have been there for quite a while (a few months) and it always worked nicely. The same not contains images that do show.

I thought I had one or two more notes with this problem. In any case the note has been there for a while.

Could you search in your log.txt if there's any reference to "67581c1ee572e1f8b0f1d383421792c9" or "Xeroxscan20181130006.jpg"? It's under Help > Open profile folder

Yes there is something:

2021-12-01 13:09:41: Synchronizer: "Sync: createLocal: remote exists but local does not: (Remote 67581c1ee572e1f8b0f1d383421792c9.md)"

Another image referenced and not showing has the following entry in the log:

2022-01-31 09:12:15: Synchronizer: "Sync: deleteLocal: remote has been deleted: Resource: (Local 63dd77e0500b86d14b73b3401472e704): (Remote 63dd77e0500b86d14b73b3401472e704.md)"

Looking forward to your suggestions.

Do you have plugin “OCR” installed? This plugin performs OCR on attached images. After completing the recognition process, it alters the Markdown by attaching the string "joplin-ocr-text:⟨blah blah⟩" to the recognized Markdown links, where ⟨blah blah⟩ is a (perhaps lengthy) string of OCR-recognized text. This string sometimes will contain parentheses. These parentheses will prevent the rendered Markdown from displaying the image.

The solution in this case is to edit the Markdown, manually deleting the superfluous parentheses from the OCR string.

I encountered a similar issue on 2022.03.05. Filing an issue is on my backlog, then I came across this post. My intention is not to hijack this thread, nor distract from the issue of the original poster here. Commenting in the possibility that my logs could help triage our issues.

I intended to post to GitHub, but as the troubleshooting has already started here...let me know, and I'll post on GitHub to track better.

environment

Joplin version: 2.7.14 (prod, darwin)
Platform: MacOS
OS specifics: 11.6.4 (Big Sur)

steps to reproduce

  • can't reproduce

other details

  • In a note, there was just text where previously there was a link I could tap to open the file.
  • Don't know if it's a sync issue: using Joplin Cloud, ie managed Joplin Server. Previously synced with Nextcloud.
  • I found one instance of this issue. There may be/have been multiple occurrences of this issue.

This is from my log, searching for a string that matches, as suggested earlier (Links to attachments lost - #8 by laurent). Included a few lines before and after.

2022-03-04 10:06:36: "ResourceFetcher: Auto-added resources: 0"
2022-03-04 10:06:36: Synchronizer: "Sync: fetchingProcessed: Processing fetched item"
2022-03-04 10:06:36: "ResourceFetcher: Auto-add resources: Mode: always"
2022-03-04 10:06:36: Synchronizer: "Sync: createLocal: remote exists but local does not: (Remote ▊▊▊▊▊▊▊▊▊▊▊▊▊▊▊▊▊b81c.md)"
2022-03-04 10:06:36: "ResourceFetcher: Auto-added resources: 0"
2022-03-04 10:06:36: Synchronizer: "Sync: fetchingProcessed: Processing fetched item"
2022-03-04 10:06:36: "ResourceFetcher: Auto-add resources: Mode: always"
  • When the issue happened, I deleted the text from my note, as it didn't connect with a file and I considered the file lost for the moment. But I extended my note history anyway, just in case I could recover what was lost, after reporting the issue.
  • Today, I grepped the string to find the matching .png and .crypted files were still present in joplin-desktop/resources.
  • I recreated the link from the screenshot. And it worked. The text becomes a working link that opens the file.
  • I still have no idea what happened. Maybe the file hadn't been present in resources, but only temporarily. I'm glad I didn't actually lose the file, but happy to help dig. Again, there may be other instances of this issue elsewhere in my notes, but I don't know how to find them.

In my case, no. Thank you for the suggestion.

I have/had a very similar problem: Quite a bunch of images did/do not show anymore in my Joplin Portable on Windows10.

The link was still in the markdown, the preview showed it as if the image was missing (the small symbol that browsers show).
The image file with the resource number of the link could be found in the ./resource folder with its proper size, as expected.
But:

  • The file could not be opened anymore with any image viewer.
  • Reason: It was fill with 0x00 instead with the image data.

This applies to all the images in notes, which I do have this problem with (quite a lot actually!).

Up to now I do not have an explanation on how this happened.

Recently I found out, that (at least some of) these images that are corrupted in the desktop version are still available in Joplin on my mobile (Android). Apparently the mobile apps database data about these images, in which they seemed to be stored, has not been overwritten by the corrupted data. The same image files on my nextcloud that I use for syncing are not corrupted either.

Maybe it helps to chase down your problem.

Do you all sync with WebDAV? Or something else?

I'm not sure I follow the story but if you removed the resource from the note, it will indeed stay in the history - however if another device, mobile for instance, has a low history retention, it might get deleted there, regardless of desktop settings.

So I don't know if this is what happened, but it could be. To figure it out we'd need to see the log on all the devices

1 Like

Speaking for myself:

Yes, that's right. I increased the history retention on all syncing clients, having remembered reading elsewhere on this forum that history is retained according to the shortest history setting on one of the clients. That's a win for this forum as a valuable knowledge base.

The log on other clients no longer include that time period. Apologies that my lengthy task backlog wiped out details that could be helpful here. I've made a note of this thread and will post here if I find more occurrences.

1 Like

Hinny, thanks for the suggestion. Yes I have the OCR plugin installed, but only to be run manually.
As a result the note in question does not have any altered markdown...

And about the retention issue: history is set to 90 days on at least 3 (out of 4) clients.
But the note has not been deleted, so I think this is not relevant for my issue.

Still hoping to get this resolved...

Is it possible to mark a specific .crypted file for decryption? That might do the trick as the .crypted files seem to be still available.

Anyone willing to reply to the above question "how to mark a specific .cypted file for decryption?"

Thanks!

I also have simple notes with a few images gone.