Links appear to be prefixed with working directory

I’m completely new to Joplin (1 day ago) and I’m using Joplin version 1.0.179 in Debian Linux. I’ve started the application from the command line with:
$ sudo sysctl kernel.unprivileged_userns_clone=1 && ~/.joplin/Joplin.AppImage

When I hover over a link in the viewer the tooltip shows the correct URL, e.g. but when I click it I get a “No such file or directory” error message and it shows the URL prefixed by my working directory; e.g. /home/richard/ If I change the working directory before running the program then the new working directory replaces the old one in the error message.

I’m sorry if I’m being dumb here – and I’ve searched the tutorial and the Support category for answers – but I’d be very grateful if someone could help me solve this.

Have you tried the new prelease build, 1.0.187? I couldbe wrong but i believe it had a Debian fix or two added including what you’re using with the kernel. It’s a testing release before the final build comes out and shouldn’t hurt to try

Thank you for your helpful suggestion. I have now tried 1.0.187 and it has the same problem. Does this constitute a bug and, if so, how should I report it as such please?

First thing, back up your notes to a jex file (File=>Export=>Jex) if you plan on going back to the old version. You’ll have to wipe out your joplin config directory to go back to that version and that will wipe your notes too.

Secondly, click the github link at the top of the page here, click Issues, search to make sure this bug hasn’t been posted and file a new bug report. Make sure you read the full template and include all of the requested info. Having a highly detailed way to reproduce the bug will go a long way.

Many thanks; I’ve submitted a bug report as you suggest.

1 Like