# Joplin Server sync Knex connection timeout errors

**URL:** https://discourse.joplinapp.org/t/joplin-server-sync-knex-connection-timeout-errors/37002
**Category:** Support
**Created:** [22 March 2024 08:41 UTC](https://discourse.joplinapp.org/t/joplin-server-sync-knex-connection-timeout-errors/37002 "2024-03-22T08:41:49Z")
**Posts on this page:** 1
**Showing post:** 3

<div class="post-metadata">

### Author: ![gealex](https://avatars.discourse-cdn.com/v4/letter/g/6bbea6/32.png) [@gealex](https://discourse.joplinapp.org/u/gealex)
#### Post date: [5 April 2024 10:14 UTC](https://discourse.joplinapp.org/t/joplin-server-sync-knex-connection-timeout-errors/37002/3 "2024-04-05T10:14:43Z")

</div>

Hello,

I have solved this issue by switching to filesystem storage.

You can find the setup for this in the official documentation : [joplin/packages/server/README.md at dev · laurent22/joplin · GitHub](https://github.com/laurent22/joplin/blob/dev/packages/server/README.md).

I basically just added `STORAGE_DRIVER=Type=Filesystem; Path=/path/to/dir` to the environment variables of my docker-compose.yml. You also need to add a docker volume `./data:/path/to/dir` to persist the data on server.

I have heavy files in my joplin notebook which, i think, were putting heavy load on the database. With filesystem storage, synchronization seems much faster and no more errors 🙂

---

_[View the full topic](https://discourse.joplinapp.org/t/joplin-server-sync-knex-connection-timeout-errors/37002)._
