# Joplin not synchronizing due to FormidableJS error

**URL:** https://discourse.joplinapp.org/t/joplin-not-synchronizing-due-to-formidablejs-error/43266
**Category:** Support
**Created:** [22 January 2025 16:37 UTC](https://discourse.joplinapp.org/t/joplin-not-synchronizing-due-to-formidablejs-error/43266 "2025-01-22T16:37:01Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![ShinZaibatsu](https://yyz2.discourse-cdn.com/flex028/user_avatar/discourse.joplinapp.org/shinzaibatsu/32/23323_2.png) [@ShinZaibatsu](https://discourse.joplinapp.org/u/ShinZaibatsu)
#### Post date: [22 January 2025 16:37 UTC](https://discourse.joplinapp.org/t/joplin-not-synchronizing-due-to-formidablejs-error/43266/1 "2025-01-22T16:37:01Z")

</div>

### Operating system

Linux

### Joplin version

3.2.11

### Desktop version info

Joplin 3.2.11 (prod, linux)

Client ID: f52fa1756c1940b9a9b1e512187bec24  
Sync Version: 3  
Profile Version: 47  
Keychain Supported: No

Revision: 2fba101

Admonition markdown extension: 1.1.0  
Athena: 2.2.3  
Backup: 1.4.2  
bytefield-svg: 1.1.0  
Conflict Resolution: 1.2.3  
Copy Code Blocks: 1.1.2  
Csv Import: 1.0.1  
Cursor Sync: 2.1.0  
[Draw.io](http://Draw.io): 2.2.0  
Editor Themes: 1.0.2  
Email Note: 1.2.2  
Ez Table: 1.0.2  
Freehand Drawing: 2.15.0  
Hotfolder: 1.2.1  
Joplin remark slides: 1.0.4  
joplin2jira: 1.0.0  
Markdown Table: Colorize: 1.2.0  
Markdown Table: Sortable: 1.2.2  
MultiMarkdown Table Tools: 1.2.1  
Note Tabs: 1.4.0  
Plugin Bundle: 0.5.5  
Remote-Note-Pull: 1.3.1  
Rich Markdown: 0.15.1  
Search & Replace: 2.2.0  
Templates: 2.4.0  
TimeTagger Plugin: 1.1.3

### Sync target

Joplin Server

### Editor

Markdown Editor

### What issue do you have?

My clients won't synchronize notes or notebooks, despite no error appearing there.  
In the server ( self-hosted ) logs, I see this:

16:33:59 0|app | Error: Parse Error  
16:33:59 0|app | at socketOnEnd (node:\_http\_server:787:22)  
16:33:59 0|app | at Socket.emit (node:events:529:35)  
16:33:59 0|app | at endReadableNT (node:internal/streams/readable:1400:12)  
16:33:59 0|app | at processTicksAndRejections (node:internal/process/task\_queues:82:21)  
16:33:59 0|app | 2025-01-22 16:33:59: [error] App: xxx.xxx.xxx.xxx FormidableError: Could not parse form: Request aborted  
16:33:59 0|app | at IncomingMessage. (/home/joplin/packages/server/node\_modules/formidable/src/Formidable.js:197:21)  
16:33:59 0|app | at IncomingMessage.emit (node:events:517:28)  
16:33:59 0|app | at IncomingMessage.\_destroy (node:\_http\_incoming:224:10)  
16:33:59 0|app | at \_destroy (node:internal/streams/destroy:109:10)  
16:33:59 0|app | at IncomingMessage.destroy (node:internal/streams/destroy:71:5)  
16:33:59 0|app | at abortIncoming (node:\_http\_server:781:9)  
16:33:59 0|app | at socketOnClose (node:\_http\_server:775:3)  
16:33:59 0|app | at Socket.emit (node:events:529:35)  
16:33:59 0|app | at TCP. (node:net:350:12) {  
16:33:59 0|app | code: 1002,  
16:33:59 0|app | httpCode: 500  
16:33:59 0|app | }

Server version:  
Joplin Server v3.0.1 ( Docker )

---

<div class="post-metadata">

### Author: ![ShinZaibatsu](https://yyz2.discourse-cdn.com/flex028/user_avatar/discourse.joplinapp.org/shinzaibatsu/32/23323_2.png) [@ShinZaibatsu](https://discourse.joplinapp.org/u/ShinZaibatsu)
#### Post date: [25 January 2025 13:32 UTC](https://discourse.joplinapp.org/t/joplin-not-synchronizing-due-to-formidablejs-error/43266/2 "2025-01-25T13:32:27Z")

</div>

Issue can be ignored. Turns out it was a problem caused by the firewall.

---

<div class="post-metadata">

### Author: ![system](https://canada1.discourse-cdn.com/flex028/uploads/cozic/original/3X/1/c/1c948e33314e232a0927789508474d8624f4270b.png) [@system](https://discourse.joplinapp.org/u/system)
#### Post date: [24 February 2025 13:32 UTC](https://discourse.joplinapp.org/t/joplin-not-synchronizing-due-to-formidablejs-error/43266/3 "2025-02-24T13:32:52Z")

</div>

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.
