Import from keep

I've imported all my notes from google keep without any hitch except all of my text is black. Since I'm using a dark theme on Joplin, The text from keep is barely visible. How can I fix this without having to change my theme to light which I won't do?

thanks in advance

Can you post an example of note (the actual Markdown or HTML)?

1 Like

Using systemd-networkd with udev

Using systemd-networkd you can automatically adjust the networking to use the phone as the gateway when plugged in.

/etc/udev/rules.d/90-android-tethering.rules# Execute pairing program when appropriate ACTION=="add|remove", SUBSYSTEM=="net", ATTR{idVendor}=="18d1" ENV{ID_USB_DRIVER}=="rndis_host", SYMLINK+="android", RUN+="/usr/bin/systemctl restart systemd-networkd.service"

You may have to adjust the idVendor attribute depending on your phone. You can check using udevadm:

$ udevadm info /sys/class/net/enp0s26u1u2

Then create the corresponding systemd-networkd file:

/etc/systemd/network/[Match] Name=enp0s26u1u2 [Network] DHCP=ipv4

Sorry, Here is the source from a keep imported note:

<en-note STYLE="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space;">Managing Pure-FTP Virtual Users<br/><br/>Managing users from the command line is pretty simple. Note that Pure-FTPd users can alternatively be managed using a MySQL database. That topic is not covered here but should be considered if you want to optimize management of thousands of ftp users on your sever.<br/><br/>Here are the commands  (you can script them) to manage your users. Be sure to replace $USERNAME with the actual user id of the individual user.<br/><br/>Creating the First User<br/><br/>sudo pure-pw useradd $USERNAME -u ftpuser -d /home/ftpuser<br/><br/>sudo pure-pw mkdb<br/><br/>&hellip; if creating an admin user with full access to the server, omit the -d /home/ftpuser parameter which would normally causes this directory to become the root of the users ftp session.<br/><br/>Creating Additional Users<br/><br/>In chroot jail:<br/><br/>sudo pure-pw useradd $USERNAME -u ftpuser -d /home/ftpuser -m<br/><br/>Not in chroot jail:<br/><br/>sudo pure-pw useradd $USERNAME -u ftpuser -D /home/$USERNAME -m<br/><br/>View a User<br/><br/>sudo pure-pw show $USERNAME<br/><br/>Change a User&apos;s Password<br/><br/>sudo pure-pw passwd $USERNAME -m<br/><br/>Update an Existing User<br/><br/>See Pure-FTPd documentation for a list of options to replace $OPTIONS.<br/><br/>sudo pure-pw usermod $USERNAME $OPTIONS -m<br/><br/>Deleting a User<br/><br/>sudo pure-pw userdel $USERNAME -m<br/><br/>Listing All Users<br/><br/>sudo pure-pw list<br/><br/>Update the User/Password Database Manually<br/><br/>(in case you forgot the -m)<br/><br/>sudo pure-pw mkdb<br/><br/>Managing the Pure-FTP Server<br/><br/>Start Pure-FTPd Server<br/><br/>sudo service pure-ftpd start<br/><br/>Stop Pure-FTPD<br/><br/>Note: This does not disconnect active users.<br/><br/>sudo service pure-ftpd stop<br/><br/>Disconnect All Active Users Immediately<br/><br/>sudo killall pure-ftpd<br/><br/>Pure-FTPd Status<br/><br/>sudo service pure-ftpd status<br/><br/>Restart Pure-FTPd<br/><br/>sudo service pure-ftpd restart<br/><br/>View Server Activity<br/><br/>sudo pure-ftpwho<br/><br/>Changing the Welcome Message<br/><br/>This message is only visible to command line users and in some FTP clients. To see what your server currently displays, open a command prompt and type:<br/><br/>ftp<br/><br/>In order to customize or even remove this message, you must create a FortunesFile file:<br/><br/>sudo echo &quot;/home/ftpuser/fortunes.txt&quot; &gt; /etc/pure-ftpd/conf/FortunesFile<br/><br/>In the fortunes.txt file, put any message you want to display or leave it empty.<br/><br/>Setting Pure-FTPd to Start-up When the Server Restarts<br/><br/>Important: You must do the following or the server will not recognize virtual users after you restart the server:<br/><br/>cd /etc/pure-ftpd.conf<br/><br/>sudo echo &apos;no&apos; &gt; PAMAuthentication<br/><br/>sudo echo &apos;no&apos; &gt; UnixAuthentication<br/><br/>sudo echo &apos;/etc/pure-ftpd/pureftpd.pdb&apos; &gt; PureDB<br/><br/>sudo ln -s ../conf/PureDB /etc/pure-ftpd/auth/50pure<br/><br/>Virtual Directories<br/><br/>Pure-FTPd supports virtual symbolic links (a.k.a. symlinks) to directories in other palces on the server -- outside your home directory. For example, you can create one using the following commands:<br/><br/>Create a symlinks to each of the different areas on the server that they will need access to:<br/><br/>ln -s /var/www /home/ftpuser/www<br/><br/>To remove a symbolic link, simply delete it. Example:<br/><br/>rm /home/ftpuser/www<br/><br/>This will only delete the symbolic link and not the contents of the folder. Just be sure it is a symbolic link and not a mounded directory though.<div>


anyone??? :point_up: :point_up: :point_up:

:cry: :cry: :cry:

What's the format of the notes originally? And how did you import them?

keep. I exported from google keep

I followed this to import from keep:

Here's a screenshot:

It's only this visible because I changed my them to solarized dark which I really don't like. I prefer the dark them but as I stated, black text on a dark them just doesn't work.

If you click on the "i" button in the top right corner, what does it says under "Markup language"?


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.