Experimental WYSIWYG editor in Joplin

A few thoughts about the wysiwyg vs inline-markdown issue:

  • Before settling on the current solution, I’ve tried 3 or 4 other editors and none of them was good enough. So at some level, it doesn’t matter that much if inline-markdown is better or not, there’s just no existing editor that would work for Joplin.

  • WYSIWYG has probably been the most asked feature for Joplin since the day it was released. It’s been asked dozens of time in many different forums. Almost never did anyone mentioned they’d like inline-markdown editing. We’re a bit biased in this forum because we like Markdown, but truth is Typora is a very niche editor and what everybody is familiar with is regular Word-like wysiwyg editor.

  • If somebody is motivated enough, they can always add Typora like feature on top of what I’m developing now. TinyMCE would definitely support inline-editing. In fact, even if we wanted Typora style editing, we’d still need the work that’s being done now first.


Thank you @laurent for being understanding about this, one more reason i prefer an inline-md editor is the space i get while taking down notes, i usually take down notes while watching youtube videos, and it becomes really annoying if you constantly need to switch panes,

while this becomes incresing annoying in split markdown mode

1 Like

I’m not sure if this is the proper location for it, but the mobile version on iOS 13.4 needs a bit of adjustment.

The tool bar needs to be raised a bit. I keep accidentally hitting the word bar at the top of the keyboard when i try to hit some of the buttons.

This thread is for the desktop wysiwyg editor. We don’t have a thread yet for the new mobile editor actually. I was planning to make an announcement for it by I’m waiting till we upgrade RN as that will fix a crash in Android.

1 Like

I am looking for a proper replacement for Wunderlist and Joplin is really promising. But this feature (I would call it antifeature) is really making me nervous. I am so tired of wasting time with making WYSIWYG editor to do what I really mean.

But on Mobile we need a working “Share” feature such that I can send stuff with the share menu to Joplin. This is IMHO more important than WYSIWYG

Why? You don’t have to use it. I have never even opened the WYSIWYG editor on my main Joplin instance. (I started it one time in my local dev build for testing purposes.)

It’s being worked on. We had a share-to-joplin on Android for text data, but the module we’ve used is not maintained properly and broke when we upgraded react-native. On iOS it never worked and I’m not sure what the status is.

Thanks for your reply. As long as you do need remove the plain markdown editor, I don’t care about the WYSIWYG stuff.

The issue with „share“ is really bad. I mostly crate todos and Notes using „share“ on my mobile …

We will see.



Hahahaha, definitely not. This would be a total showstopper - at least for me.

Yes, I agree. That’s why I haven’t upgraded my Android version. The last version that had the share-to functionality (only for text though) was 1.0.316. If you are using iOS, you are currently out of luck.
Please note: If you use E2EE, you won’t be able to use 1.0.316, because the encryption algorithm has changed and 1.0.316 does not understand this new algorithm.


I’d also like to get this back. For the interim, I can sometimes use copy and paste into Joplin from wherever. Sometimes I end up emailing myself.

For those of you who wanted to try this out and couldn’t find the mentioned menu: View => Layout button sequence, and choose "Split / WYSIWYG"

You now I have to click the Code View button to toggle back and forth

1 Like

Can we get some keys for entering katex on toolbar like “, $$”?

This is definitely moving in the right direction! I love it!!! THANKS!

Hi, I love the new WYSIWYG editor, but unfortunately after a few weeks without any problem, I'm experimenting a very annoying bug : some of my notes are emptied all of a sudden, and it happens once a week :frowning: Sorry I don't know yet how to declare a bug

@nokoa77, how does it happen exactly? Is it when you edit a note that suddenly the content goes away? Or when you go back to a note?

When it does happen, could you check the log? https://joplinapp.org/debugging

By the way you should be able to recover most of the note from the note history feature.

Thanks for the anwser and debug link, I will check the logs next time.
Lastly it happened when I went back to notes, so I don’t know exactly when the emptying really happened (when I last edited the note or when I went back to it).
Yes the version history helped me twice, but on the last occurrence of the bug it was a big note that I hadn’t edited since some time (since Joplin installation or 180 days) so it didn’t help. But I will find it in some backup so it’s not bad. And now I will keep note history for 365 days.
PS : Joplin Desktop 1.0.227 (but bug happened with 1.0.224) on Mac OS X 10.15.5 and on Windows.

Maybe it’s something specific to your notes, like some particular markup or size of the note, etc. Once you got the note back, could you try to make some changes, switch to another note, go back to it, etc several times like this to see if you can replicate the issue?

Hi and many thanks for your messages Laurent (and thanks for developing this nice app I can't live without :slight_smile: ),
Here is how I can replicate the issue to empty a note in WYSIWYG mode on my config (1.0.224 or 1.0.227 and Mac OS X 10.15.5 or 10.15.6, Joplin installed with homebrew cask) :
1/ open a long note 'N' in notebook A
2/ edit this note 'N'
3/ immediately change the notebook to another one (whatever but another one), let's say notebook B
4/ I see a 1st bug then : the note 'N' also appears in the notebook 'B' above the other 'normal' notes of notebook B
5/ switch back to notebook A
6/ then I see the 2nd bug : the note 'N' I just edited is now empty, and the note history contains an old version that doesn't include the modifications I just made.
Here is the CONSOLE log : Framabin
Here is the log.txt extract : Framabin (password : titi)
We can see in the LOG.TXT extract that the note "KM" has a BODY the first time (anonymized to "TRES LONG TEXTE") and then the body is empty ("body":"").
I hope this can help,

1 Like

@nokoa77, thanks I can indeed replicate this and will be looking at it.

1 Like

Just wanted to add my thanks to Laurent. Coming from the now-overly-bloated Evernote, I love the speed, simplicity, transparancy of Joplin.

The WYSIWYG editor really useful, and I now use it the majority of the time. My use case:

  • I'm taking quick notes in meetings or during research (Joplin is fast)
  • Visual formatting is really useful for quickly seeing thoughts and ideas on the page
  • Website and note links are hidden but clickable
  • Uses the full screen real estate

However I love that markdown is the underlying language, and having the markdown editor there lets me prune any straggling formats / links / etc if required.

The fact that they're integrated into one app (no external editors required) is the perfect combination - great work!