Error 6 when building on linux

Actually after some issues in AUR also previously I have since then used the script mentioned on the homepage. It worked fine for me in Arcolinux (arch-based) and Bunsenlabs (debian-based). Perhaps you can try that also? And otherwise the Appimage usually worked for me also. Because of the remark of @tessus above I stopped using the AUR version completely: you are dependant on the maintainer of the package. I'd give the script a try :wink:

I'm not saying that maintainers are not doing a great job. It's just that we can't support packages from other people.
However, I've noticed that in one case the desktop and terminal app are bundled into one package. IMO this is a mistake and can lead to certain problems. But that's something the maintainer has to deal with.

Just tried the installer, no luck. I only get a big white frame which is unresponsive by manually invoking it in terminal (desktop icon doesn't produce any result). I cant seem to find anything in the logs, even with debug flags on.

No, neither did I. But when using the AUR I think it is best to follow the suggestions of the 'application owners' and to read some comments or look for the latest date of an update. For instance Balena Etcher has a very active maintainer(s), their update to the AUR is always one day after an application update. That works really well.

My experience is only with Manjaro and Arcolinux (Arch derivatives) so I am not sure about plain Archlinux. What I read re: Joplin on Debian though is that non-functioning can also be related to security as needed by the kernel (then start with the option --no sandbox) or with the implementation of Electron. The search goes on :wink:

@tessus Maybe I misunderstood, but isn't the installer script supported either ?

Manjaro in principle should be same as Arch Linux.

The installer script is supported.

I cant get it to work with the installer script either. A big white unresponsive frame, no menu item works. I cant any find logs with useful info either .

edit: I just tried on two different machines with arch right now. Works on one, not the other (same symptoms). A bit blank on what I can do to produce some meaningful info for you.

We need debug data. If we don't see error messages or console output there's not much we can do.

As mentioned, the debug flag doesnt produce any output in the logs.

$ cat ~/.config/joplin-desktop/flags.txt
--open-dev-tools --debug -log-level debug

Now, looking for any log files:

$ ls -al ~/.config/joplin-desktop
.
..
flags.txt

and

` $ ls -al ~/.joplin`
  Joplin.appimage
  VERSION
  . 
  ..

Let me know if there is anything specific you need.

edit: the one machine that it works on, the log.txt is visible in ~/.config/joplin-desktop/. Thus, I believe the app doesn't even get to the point where a log file is created.

edit2: Here is a window of how the Joplin window looks

edit3: node version v14.13.1 (on all 3 machines, 1 working, 2 not. all installed with script, same kernel ).

As far as I can see this tool is building Joplin from source... except that it's hiding the build output so we can't know anything.

If I were to build from source, I'd just grab it from GitHub and run npm install, then you can see everything. Building an app can be complicated enough without introducing another layer that hides what's happening.

No, the OP is using the linux installer script.

But he mentioned he's using a fork of the AUR package?

Yes, that was the first post, but then he also tried....

Unfortunately I don't know how to debug this white frame issue. I remember that there was something like early logging, but I can't recall to turn that on.

Normally everything's in https://joplinapp.org/debugging And I think it's also possible to open the dev tools from one of the menus of the white window.

I remember there was no debug log in certain situations. I had to change something in the code, so that logging started early - otherwise logging only starts when the app is up, but if the app doesn't come up, there's no log. And this seems to be happening here.

I suspect a module incompatibility or a node issue. Either way, it's hard to say without any info.

I'll update if I get anything to report.

Should someone have ideas to how one could produce some productive info, please don't hesitate to let me know.

In the meantime I'm using the cli version. -And for all the comments, and very fast replies, thanks :slight_smile:

Forgot to mention that the aur package was updated, desktop still having same problem, but the included cli worked.

I suspect a module incompatibility or a node issue

My guess also. Should I find out what / which, I'll let you know.

Some progress. I have tried to manually build the app from source, works. fine. Tried with release-1.2.6, pre-release 1.3.9 and dev. The problem seems to occur after this command:

$ npm run dist

None of the binaries (even unpacked) works after that command. All leading to the white frame without any response. I can reproduce this across various version.

Oh, and if I run it as a flatpak, it works.

Unfortunately, my foo with the node ecosystem is too weak to come to some conclusion.

Works:

$ npm install --cache ./npm-cache
$ cd ElectronClient
$ npm install --cache ./npm-cache
$ npm start

Doesn't work:

$ npm install --cache ./npm-cache
$ cd ElectronClient
$ npm install --cache ./npm-cache
$ npm run dist
$ cd dist 
$ chmod +x Joplin-x.x.x.AppImage
$ ./Joplin-x.x.x.AppImage

Unfortunately I currently do not have a Linux machine to run any tests.