ECONNREFUSED Win10 --formerly titled "Sorry, you can't include links in your posts."

Joplin 2.11.11 (prod, win32)

Client ID: b9d33fe803c242c18720a014a72d3f27
Sync Version: 3
Profile Version: 43
Keychain Supported: Yes

Revision: 6886f6f

So here is where I would have included the tail of the logfile:

The topic uploader at discourse.joplinapp. "barfed" on URL "links", so I tried my best to fool the uploader sentry... sorry! I'm new here myself..[what IS a link?? even links WITHIN the logfile?????!]:

2023-07-27 08:42:43: config-shared: "Sync settings have been changed - scheduling a sync"

<the remainder of this file has been truncated pending my understanding how I am triggering the uploader to complain about "including links in my posts."

"An error occurred: Sorry, you can't include links in your posts."

Someone might explain to me how to get around this, as I could see nothing in "community guidelines" on the technicalities of uploading a topic.

Thanks in advance...

use a code block

links here

or any type of code or logs. 
that's why there is a code block available in the first place.

Got it! Thanks so very much, Helmut.

So here is the tail of the logfile:

2023-07-27 08:42:43: config-shared: "Sync settings have been changed - scheduling a sync"
2023-07-27 08:42:53: "Preparing scheduled sync"
2023-07-27 08:42:53: "Starting scheduled sync"
2023-07-27 08:42:53: Synchronizer: "Sync: starting: Starting synchronisation to target 6... supportsAccurateTimestamp = false; supportsMultiPut = false [1690461773768]"
2023-07-27 08:42:53: Synchronizer: "Indexing resources..."
2023-07-27 08:42:53: "ResourceService::indexNoteResources: Start"
2023-07-27 08:42:53: "ResourceService::indexNoteResources: Completed"
2023-07-27 08:43:05: config-shared: "Sync settings have been changed - scheduling a sync"
2023-07-27 08:43:15: "Preparing scheduled sync"
2023-07-27 08:43:15: "Starting scheduled sync"
2023-07-27 08:43:15: Synchronizer: "Sync: starting: Starting synchronisation to target 6... supportsAccurateTimestamp = false; supportsMultiPut = false [1690461795726]"
2023-07-27 08:43:15: Synchronizer: "Indexing resources..."
2023-07-27 08:43:15: "ResourceService::indexNoteResources: Start"
2023-07-27 08:43:15: "ResourceService::indexNoteResources: Completed"
2023-07-27 08:43:16: Synchronizer: "FetchError: request to <h-t-t-p-s>:// failed, reason: connect ECONNREFUSED
FetchError: request to failed, reason: connect ECONNREFUSED
    at ClientRequest.<anonymous> (C:\Program Files\Joplin\resources\app.asar\node_modules\@joplin\lib\node_modules\node-fetch\lib\index.js:1491:11)
    at ClientRequest.emit (node:events:526:28)
    at TLSSocket.socketErrorListener (node:_http_client:442:9)
    at TLSSocket.emit (node:events:526:28)
    at emitErrorNT (node:internal/streams/destroy:157:8)
    at emitErrorCloseNT (node:internal/streams/destroy:122:3)
    at process.processTicksAndRejections (node:internal/process/task_queues:83:21)"
2023-07-27 08:43:16: Synchronizer: "Sync: finished: Synchronisation finished [1690461773768]"
2023-07-27 08:43:16: Synchronizer: "Operations completed: "
2023-07-27 08:43:16: Synchronizer: "Total folders: 0"
2023-07-27 08:43:16: Synchronizer: "Total notes: 0"
2023-07-27 08:43:16: Synchronizer: "Total resources: 0"
2023-07-27 08:43:17: "DecryptionWorker: cannot start because no master key is currently loaded."

By the way, I put the desktop into the DMZ on the LAN, and I can
see the IIS and the joplin subdirectory from a browser on the smartphones which are connected by WiFi to the LAN router. (using "" but not an actual domain name)

This might be of interest to other newbies:

So here's what I did to get to this condition:

  1. I loaded Joplinapp onto my android phone from Play Store.
    I was using the "file system" method of synchronisation. I put a folder onto my SD chip.
    Everything works just fine.

  1. Then my wife asked to be part of my "Honey-do" lists.
    So I figured I could put up an instance of a webDAV server on the desktop machine I have.
    I loaded Joplinapp onto my Win 10 Pro (i5-3570, yes, quite an old) desktop machine.
    I was using the "file system" method of synchronisation.
    Everything works just fine.

  2. Then I discovered a script at:

This will put an IIS instance up on your personal Win10 Pro platform. Microsoft's "Internet Information Server".

You can control it by right-clicking "This PC" / Manage and expanding "Services and Applications" and clicking on the "IIS Manager" .
I have the "root" directory for IIS at "c:\inetpub\wwwroot" and then I created a subdirectory "joplin" for the sync files

Now here you have to poke around IIS manager, to get the permissions for the file right, and so on.

I started out with this inside my router LAN, so the
webaddress for the webDAV is

and I set the webDAV username and password for a new Win10 account I set up on my desktop machine for my family to use,

i.e., ""  pw="whatever_password"

By making this a standard account, I don't need to eventually put my "master Win10 password" to my personal administrator account named, say, "Daniel" out on the web-- I just use that for logging into my desktop from my desktop machine. In other words, I will get the webDAV to work using a "less dangerous" username and password, which eventually can used from anywhere by family smartphones, and by multiple users. And I don't want to put that one account into the group policy editor as IIS_IUSRS, meaning "Built-in group used by Internet Information Services".

Are you with me?

By the way, newbies, the snap-in you get when you right-click "This PC" then "Manage" has folder share permissions under "Computer Management (local)/System Tools/Shared Folders/Shares"

Don't think I don't consider myself a newbie with IIS. I am much more familiar with Apache on FreeBSD, and will get around to putting that up....

OK, but before I make this fully accessible from more than just the home (inside the LAN bubble) but rather from the greater internet, which I will do by

  • A) Buying a domain name for my family (like "")

  • B) setting up DDNS for that domain name from a free DDNS provider like

I have run into this snag, the ECONNREFUSED error, which I get when I click (in the desktop joplin app)
Tools/Options/Synchronisation/ and then scroll down to
"Check Synchronisation configuration"

having set up the webDAV URL to


and the webDAV username and password to

"" [i.e., the new user I added to my basic win10 user list] and the corresponding password.

So I hope someone will check my log, and help me get on with the DDNS version of this.

Another snag, for the record, is that in the meantime, all the family smartphones are sychronising with on-device file system folders.

I believe that I will eventually be able to

  • 4A) export the last known good synchronisation on each phone to a JEX file (Joplinapp: "File/Export/JEX format...",

And just exactly how do I create a JEX from the android version???
and then

  • 4B) import to the desktop with IIS from each of the several JEX files physically transfered [Back in the very early days of the internet (once called uucpnet*), we used to call this transfer "by sneaker-net" meaning "shoes", you physically walk the outlying JEX file by flashdrive (or now, by cable, eliminating walking the flashdrive, but I guess you have to bring the smartphone itself to the cable at the desktop machine, now with IIS....)

*uucpnet" = "unix-to-unix copy net" this was in the very early days, when you had to designate a known path from your machine to that of your friends, using "bang" notation, before the advent of the domain name /DNS system, developed by unsung heroes of their time, and after several years of wringing out the RFC paper for such... sigh! the good ole days-- did you know that the T1 speed was determined by AT&T engineers and was dependent on the distances between street manhole covers over the cable relaying vaults in Chicago, where the Ma Bell engineers were working out the multiplexing of packets over uncle worked on microwave towers for Long Lines, and we once were privileged to get Ma Bell to pick up and deliver email directly to our servers using uucpnet, so when email had to go across country, it would hop out and back to "Indian Hill Network Processor #4 ihnp4 (with a much simpler, one hop bang-format address of "!ihnp4!myserver"), located in Aurora IL, at the Bell "Indian Hill" labs where a giant barn was the prototype for the #5 ESS electronic switching system.

So almost all the traffic on the internet was going across country courtesy of Ma Bell, and this one little unix server, ihnp4. Ihnp4 was in a single 19" rack, about the size of a refrigerator. A tour there left me awestruck by the FIOS prototypes, using 50Mbps (!!!) optical fiber. Remember, we were using 1200 baud modems at the time. This was in the early 1980s.....

Please enjoy the reminiscences, I'm really not trying to show off.... just get you to read my post, and give me some help, please.

Thanks again, Helmut


Solved-- this is some sort of server-side error, not fixable in Joplin. I suppose other ECONN* errors are the same.

Thanks to all the many, many members who have yet to read the post.