Home / GitHub Page

Data lost after update

I see in the logs that the Joplin can’t find the encryption key “DecryptionWorker: cannot start because no master key is currently loaded.”
2019-08-16 07:37:27: “Trying to load 0 master keys…”
2019-08-16 07:37:27: “Loaded master keys: 0”

The same for me.
I run command. No output. No error message. That’s at MacOS.

Still not enough info to help fix that issue unfortunately.

No, it does not.
I restored the /Users/kirill/Library/Application Support/Joplin,
start the latest version of Joplin. There is no more error message. But all notebooks are still empty.

How can I find logs?
/Users/kirill/Library/Logs/Joplin is empty, no files.

@Limping, could you try the following please?

  • Close the application completely
  • Restore the profile and check with a SQLite brower or the command above that there are indeed notes inside. The file would be in ~/.config/joplin-desktop/database.sqlite
  • Start the application
  • Check again ~/.config/joplin-desktop/database.sqlite to see if there are notes inside

The point is to validate that it is indeed the app that is somehow wiping out all the notes.

Also if you could post the complete logs after having done this that would be great. It’s in ~/.config/joplin-desktop

Now I found a place in the log where my notes disappeared:
2019-08-15 12:26:48: “TaskQueue.stop: syncDownload: waiting for tasks to complete: 0”
2019-08-15 12:26:48: “TaskQueue.stop: syncDownload: Done, waited for 0”
2019-08-15 12:26:49: "Operations completed: "
2019-08-15 12:26:49: “fetchingTotal: -”
2019-08-15 12:26:49: “Total folders: 5”
2019-08-15 12:26:49: “Total notes: 63”
2019-08-15 12:26:49: “Total resources: 67”
2019-08-15 12:31:50: “Running background sync on timer…”
2019-08-15 12:31:50: “Scheduling sync operation…”
2019-08-15 12:31:50: “Preparing scheduled sync”
2019-08-15 12:31:50: “Starting scheduled sync”
2019-08-15 12:31:50: “TaskQueue.stop: syncDownload: waiting for tasks to complete: 0”
2019-08-15 12:31:50: “TaskQueue.stop: syncDownload: Done, waited for 0”
2019-08-15 12:31:56: "Operations completed: "
2019-08-15 12:31:56: “fetchingTotal: 323”
2019-08-15 12:31:56: “fetchingProcessed: 323”
2019-08-15 12:31:56: “deleteLocal: 323”
2019-08-15 12:31:56: “Total folders: 0”
2019-08-15 12:31:56: “Total notes: 0”
2019-08-15 12:31:56: “Total resources: 0”
2019-08-15 12:32:02: “SearchEngine: Updating FTS table…”
2019-08-15 12:32:03: “SearchEngine: Updated FTS table in 287ms. Inserted: 0. Deleted: 63”
2019-08-15 12:34:20: “RevisionService::maintenance: Starting…”
2019-08-15 12:34:20: “RevisionService::maintenance: Service is enabled”
2019-08-15 12:34:21: “RevisionService::collectRevisions: Created revisions for 0 notes”
2019-08-15 12:34:21: “RevisionService::maintenance: Done in 1000ms”
2019-08-15 12:36:57: “Running background sync on timer…”
2019-08-15 12:36:57: “Scheduling sync operation…”
2019-08-15 12:36:57: “Preparing scheduled sync”
2019-08-15 12:36:57: “Starting scheduled sync”

Ok, I will do it.
This is logs before restore, as I see now: https://d.pr/free/f/8232BE

Yes! Now I see the result. SQLite shows my notes.
I start the application and my notes are here.
I check SQLite again, it’s Ok. I see the my notes.

This is logs after perforning restore:

I went back to Joplin-1.0.164 as 165 does not work.

UPDATE:

One of the Linux laptops is running 1.0.161, and is synced to the same notes WebDAW folder. I just opened it to find it missing all the notes.

So conclusion: Using 1.0.165 once, breaks all other synced clients (but not on Android), running older version.

Switching back to older versions for now.

@clammer @RebelCoder @RomanB @Limping

From which version did you upgrade to 1.0.165 and experience the data loss described in this topic?
I upgraded from 1.0.161 and my notes are still here. I’m trying to ascertain, if this happens only from a specific version or from any version (when it happens).

So from my posts above I came across two issues:

I had 1.0.164 (as I do daily scheduled updates in the background so my Joplin is always latest version) and updated to 1.0.165 on just ONE out of FOUR Linux PSs.

  1. After update on ONE of the PCs and restarting Joplin, All notes on this PC were gone. Removing all settings and re-setting things up did not help as notes were synced but were gone on a next start.

  2. I went to check on other THREE Linux PCs which run 1.0.164 (and one runs 1.0.161) and after Sync all notes were gone from earlier versions of Joplin on the rest of the PCs as they all are synced to one WebDAW folder.

So my main PC, after getting an upgrade from 1.0.164 --> 1.0.165 somehow messed up some settings/configs in that WebDAW folder and now all other Joplin instances, pointed to that WebDAW folder got the same issue - no Notes.

Solution I found:
I downgraded to 1.0.164 and re-synced/re-configured all Joplin instances and now notes are syncing fine.

NOTE: this issue did not effect Android instances.

I hope this is detailed enough description, as a combination of all other replies.

It’s clear that if notes are deleted from the sync target that all other clients will remove these notes too.
So apparently upgrade 1.0.164 --> 1.0.165 results in data loss.

1.0.161 --> 1.0.165 works for me, so the question is does it work for you too?

I’m trying to narrow down the issue. So basically I want to know, if this data loss only happens when upgrading from 1.0.0164.

I am on 1.0.0164 and will attempt an upgrade right now (via that .sh script)

Stop. I think we have already established that your upgrade from 1.0.164 --> 1.0.165 did not work.
Why do you want to do it again?

OK. Will keep the 164 on THREE PCs and 161 on one PC. What do you want us to try next ?

It would be great if you could upgrade from 1.0.161 to 1.0.165 to see, whether you also lose your notes with this upgrade path.

Don’t forget to backup your notes!!!

OK.

1.0.161 --> 1.0.165 works. All notes are still there after restarting Joplin on all PCs and syncing multiple times.

Perfect. So now we know that an upgrade from 1.0.164 to 1.0.165 is the problem.

To solve your immediate issue: install 1.0.165 on all machines where 1.0.164 is currently installed. Do not start Joplin. Copy the profile directory from the PC you have just upgraded from 161 to 165 over the profile directory on the other machines. Done.

Just in case, don’t forget to have a backup of your notes!

Yes. I actually did it already :slight_smile: Thanks!

1 Like

Migrated from 1.0.161 to 1.0.165 without issues.
But in some log dump above I can see:

2019-08-18 12:54:20: "Scheduling sync operation..."
2019-08-18 12:54:20: "RevisionService::runInBackground: Starting background service with revision collection interval 600000"
2019-08-18 12:54:21: "DecryptionWorker: cannot start because no master key is currently loaded."
2019-08-18 12:54:24: "Scheduling sync operation..."

Is this the root cause? Missing encryption key?

Do you use encryption?