Certificate error during upgrade

Hello there,
due to sync prerequisites (OneDrive states that the local client is obsolete) I'm trying to upgrade my client from 2.1.9 to 2.7.13 using this command:

My system:
Kernel: 5.16.9-200.fc35.x86_64 x86_64 bits: 64
Desktop: GNOME 41.4 Distro: Fedora release 35 (Thirty Five)

Please note that I have another laptop which does not have problems:
Kernel: 5.16.9-100.fc34.x86_64 x86_64 bits: 64
Desktop: KDE Plasma 5.22.5 Distro: Fedora release 34 (Thirty Four)

Thanks for any help!


We don't manage the certificates in this domain (GitHub does) but I'm sure they are valid. Do you have a proxy or firewall that could interfere with the connection?

Well, actually not!
To be sure I tried with a hotspot connection via mobile: same error.
I tried also a quick & dirty workaround, adding the parameter --no-check-certificate to the wget command in a local copy of the script, but it doesn't work either.

Downloading the joplinapp-org.pem certificate and running "update-ca-trust extract" made the job.
Thanks anyway for the time spent.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.