Bug while testing the new edit ressources functionality in 1.0.218

Using 1.0.218 portable version on Windows 10

I have a note with two jpgs. I rightclick on one and select "Open...". The message I get is this:

Roughly translated from German to English it says:
"There is no app associated to run this file. Install an app or create an association on the settings page for standard apps if there is already an app installed"

My Windows 10 is definitely configured to open jpgs with Irfanview:
And when I double click an jpg in Explorer, Irfanview opens the image just fine.

What I see in the portale profile folder is a edited_resources folder looking like this (yes, my Explorer is configured to show extensions!):
Is it possible that the extensions are missing and because of that the OS does not find a suitable app?

Edit: Editing one file in edited_resources indeed got picked up by Joplin, so the filesystem watcher works :slight_smile:

Yes this is strange as normally it should have appended the file extension. Any chance you could check your database.sqlite file in SQLite Browser? Then if you could run this query to check the properties of your resource: select * from resources where id = "RESOURCE_ID"

Good old HeidiSQL says this:

Looks fine to me.
Hope the screenshot is readable. mime is image/jpg, file_extension is jpg

One issue I see is that the mime type is “image/jpg” but it should be “image/jpeg” so probably it’s not set properly somewhere. Do you remember how this image was added to your note?

I use Greenshot to make partial rectangular screenshots and paste them directly from my clipboard to Joplin via Ctrl-V.

I just tried to add a png and a jpg from my file system to Joplin via drag and drop. Here opening and editing works fine.

So you mean that Greenshot does something wrong?

No probably Joplin is setting the wrong mime type somewhere, but I’ll also change the code so that it handles resources both with image/jpg and image/jpeg mime type.

1 Like

I can confirm that it works for me now with v1.0.220.