Are Android 10 and Linux password charsets not compatible?

Hi!
I installed Joplin v. 1.0.322 on my Android 10 mobile.
I synchronized to my webdav server, and then I encrypted it.
After that I installed Joplin v. 1.0.193 on my Linux machine. My Linux is “Mint 19.3 Tricia” which is based on Ubuntu 18.04.
I synchronized with my webdav server and all notes were added encrypted on my Linux client.
On the encryption page I could see the masterkey was the same as in the mobile client.

When I enter the password absolutely nothing happens when I press the save button.

Are there a problem with different charsets on Android 10 and Linux?

I tried to reinstall on both Android and LInux(Yes, I deleted all data to get a fresh install).

Regards
Henrik

Did you encrypt from mobile to Linux instead of Linux to Mobile?

This is how I did:

Installed Joplin on Android 10 (OnePlus 7T)
Connected to my OwnCloud webdav server
Added some notes in the Android app
Activated encryption and wrote down the password
Verified that the data on the OwnCloud webdav server was encrypted
Then installed Joplin client on Linux
Then I connected from my Linux to the webdav server
Then I synchronized the encrypted data from the webdav to the Linux machine.
On the Jopllin main screen I could see labels “Encrypted” for notebooks and notes.
I choosed “settings -> encryption”
I verified that the masterley on Android and Linux was the same.

I entered the password on the Linux client, but when I pressed save, nothing happens. Absolutely nothing. There was a X marked at the right. I think it means that the password is incorrect?

I deinstalled the Android app and the Linux client including the data in the hidden directories, and tried the procces a second time without success.

I used the same password in both cases and it was written down. So I have not made any mistakes when entering the passwords.

Very strange.

Regards

So, what’s going on is you did the steps in the wrong order. It’s pretty common and was laid out in the Welcome Notebook that shows when you uninstall and reinstall on Android.

  1. If you are just testing, go ahead and delete the notebooks and notes altogether, sync them to the server, and delete ~/.config/joplin-desktop on your desktop.

  2. Uninstall and reinstall on your android phone.

  3. Read the encryption welcome docs. You’ll be best to encrypt directly on your desktop, set the master password there, and sync to your server.

  4. Open Joplin on your android phone and set to your server info in config and sync without setting password yet.

  5. Once you see a yellow bar at the top that asks for the password, click that and enter it there.

  6. Click Save button to make sure it’s correct.

  7. Get a check mark, you should be good.

This is honestly a common support question here and is almost always a “I didn’t read the manual” issue. Hell, i did the exact same thing. :wink:

If it’s still not working after following these steps, check the Github issue tracker, because this should be a fairly common bug. If not, then create a bug report with as much info as you can muster including your current character sets.

OK. Now I think I have a running system.

I read the encryption welcome docs(I always RTFM, but apparently not this time SMILEY). It states that: “It is recommended to start with the desktop or terminal application”. Well, maybe it should be stated in the docs: “Start with the desktop or terminal application” because I thought it should work the other way around as well. But it didn’t.

Anyway. The following solved my issue:

  1. Delete Android app
  2. Delete all notebooks in desktop client
  3. Closed the Joplin desktop client
  4. Delete ~/.config/joplin-desktop
  5. Checked that my OwnCloud client on desktop was set to: “Synch hidden files”. I found that this was not enabled by default in the OwnCloud client. Really annoying to find out.
  6. Deleted all files in my local synched folder in my desktop filesystem incl. hidden files
  7. Checked that the webdav folder was empty in my OwnCloud
  8. OK. Started Joplin and used target “Filesystem” pointing at my local Owncloud folder.
  9. Why? Because If I used the webdav synchronization method directly to my OwnCloud server, it took several minutes to complete a synchronization (At least on my Linux system). By choosing filesystem synchronising the Owncloud client synchronized almost instantly.
    10 . I encrypted the data on the desktop client and synchronized with server via filesystem and Owncloud client
  10. I installed the Android app and connected to my webdav server and synchronized
  11. Now I had the encrypted data on my android app
  12. A yellow bar at the top that asks for the password
  13. I selected ‘use encryption’, checked that the masterkeys was the same and entered the password
  14. All notesbooks and notes got decrypted.
  15. I tested various scenarios by changing data on Android and desktop and synchronize. It works fine.

I know this is a long description, but maybe other people run into same problems.
I don’t know if the docs should be updated including pitfalls?

Be aware that the OwnCloud client on the desktop does not automatically sync hidden files which Joplin uses.

Many thanks for directing me to a working solution.

Stupid me. Off course I cannot sync with local filesystem on desktop client.

The webdav sync in the desktop client is extremely slow.